Imprimer la Page | Close Window

Nouveau el. Skitter Slider (images) - testez svp

Imprimé depuis: Forum openElement
Categorie:

openElement


Nom du Forum: Éditeur d'éléments
Description du Forum: Discussion sur l'éditeur d'éléments
URL: http://forum.openelement.com/fr/forum_posts.asp?TID=20526
Date: Nov 30 2020 à 5:32pm
Version logiciel: Web Wiz Forums 10.18 - http://www.webwizforums.com


Sujet: Nouveau el. Skitter Slider (images) - testez svp
Posté par: Dmit OE
Sujet: Nouveau el. Skitter Slider (images) - testez svp
Posté le: Feb 26 2015 à 10:39am
Bonjour,

Le nouveau element a telecharger, avant de le mettre dans la gallerie d'elements pouvez-vous le tester? Telechargez ici:

http://dmit.izihost.com/test/skitter/WESkitterSlider1.zip" rel="nofollow - http://dmit.izihost.com/test/skitter/WESkitterSlider1.zip

Nouvelle version, avec des corrections et le mode "remplir/couvrir" demandé à nombreux reprises:
http://" rel="nofollow - Encore quelques améliorations qui concernent les contrôles d’accès rapide (thumbnails et points) pour sélectionner une image correctement (avant c’était l'image suivante qui s'est sélectionnée), et une décalage d'affichage des aperçus:
http://" rel="nofollow - - http://dmit.izihost.com/test/skitter/WESkitterSlider1_c1.21.zip

Pour les utilisateurs de OEGuideline - corrections du code CSS pour eviter les erreurs dans le rapport:
http://dmit.izihost.com/_el/WESkitterSlider1_v1.22.GuidelineOK.zip" rel="nofollow - http://dmit.izihost.com/_el/WESkitterSlider1_v1.22.GuidelineOK.zip

Fermez un projet, dezippez l'archive, mettez le DLL dans le dossier Common/Elements du projet, ouvrez le projet, trouvez l'element D) Skitter Slider dans Elements->Media, et essayez de jouer un peu avec. C'est l'adaptaion de mon slider prefere (de Larsene aussi il semble) en mode responsive et integree dans OE. On peut associer des textes et des liens a chaque image, localizable (plusieurs langues).

Je pense que ca manque a beaucoup de monde depuis trop longtemps.

Cordialement
D



Réponses:
Posté par: Bridet
Posté le: Feb 26 2015 à 11:51am
Ca marche! Je vais maintenant un peu voir comment gérer les transitions.


Posté par: Bridet
Posté le: Feb 27 2015 à 10:15am
Bonjour,
J'ai testé un peu tout!
Régler transitions : facile
Pour l'emplacement des boutons, ça pourrait être amélioré, déjà on ne peut positionner ceux de navigation, au minimum pouvoir les mettre à l'extérieur de l'image.
Les boutons de contrôle se placent à cheval sur l'image (quelque soit la position choisie sauf center).
Pas de trace des "points" alors que sélectionnés ni du titre (du diapo).
Les vignettes se mettent en-dehors du conteneur.
Enfin, le diapo ne semble pas responsive (j'ai élargi l'image au max du conteneur et elle ne se réduit pas si on rétrécit la fenêtre du navigateur).
J'ai peut-être loupé quelque chose, donc visible ici www.gite.vervoz.be



Posté par: Dmit OE
Posté le: Feb 27 2015 à 10:39am
Merci pour vos tests.

- Les boutons de controle dependent du "theme", dans "round" ils sont dehors par exemple. Sinon il faut utiliser les Zones de style pour les mettre ou vous voulez, mais c'est un peu avancee comme tache.

 - "Responsive" signifie que le slider est capable de s'adapter a la taille choisi dans OE, par exemple 100% du Panneau d'elements contenant cet element. D'ailleurs, maintenant (derniere versin OE) on peut specifier le rapport largeur/hauteur fixe pour des Panneaux, ce qui est tres pratique pour ce Slider.

 - Les points doivent etre en bas, c'est etrange.. pouvez-vous les activer et publier en ligne pour verifier? Ainsi que tous les autres options qui vous genent. (Il est vrai que pour des petits tailles, les boutons sont trop larges).




Posté par: Bridet
Posté le: Feb 27 2015 à 11:03am
Les points doivent etre en bas, c'est etrange.. pouvez-vous les activer et publier en ligne pour verifier?
Mon lien est bien à jour (points activés www.gite.vervoz.be


Posté par: Dmit OE
Posté le: Feb 27 2015 à 11:14am
Selon le fichier de config, les points (ainsi que les contrôles) sont désactivés pour la version en ligne.

Les textes ne s'affichent pas parce qu'ils ne sont pas spécifiez (il faut les mettre pour chaque image dans la liste de la propriete "Images").


Posté par: Bridet
Posté le: Feb 27 2015 à 11:27am
Bon, je crois que je n'avais pas publié ma dernière version, boulette un jour, boulette toujours!
Quand je parle du titre, ce n'est pas le titre de chaque dia qui marche mais le titre dans "commun" que je pensais être le titre du diaporama.


Posté par: Dmit OE
Posté le: Feb 27 2015 à 12:10pm
Non c'est la propriete commun a tous les elements, petite rectangle qui s'affiche au survol+arret de la souris.


Posté par: Dmit OE
Posté le: Feb 27 2015 à 12:11pm
P.S. Je pense que les points se desactivent en cas d'utilisation des vignettes images (car c'est au meme endroit).


Posté par: nico38
Posté le: Apr 01 2015 à 5:09pm
ah il a l'air bien ce nouvel élément !

par contre quand je survol les vignettes : on voit les 2 vignettes à la fois au lieu d'une seule :
http://www.hostingpics.net/viewer.php?id=9951988699.png" rel="nofollow">

2. par defaut les numeros de pages sont bottom:-40px. Sur OE, si je vais dans la section de style "numeros de images" et que je mets distance bas 0px : ce n'est pas pris en compte (même en mettant !important) : sur oe pas dans un bloc de code

3. si on veut que le texte s'adapte en hauteur (si trop de texte ou écran plus petit) :
- en mettant auto en hauteur : le texte ne "reviens pas à la ligne"


Posté par: Maurice306
Posté le: Apr 01 2015 à 5:59pm
Bravo Dmit, Il parait sympa, pas tout exploré sur les dimensions possibles Thumbs Up

-------------
La vie est belle !!!....., elle est comme chacun se la fait. Ne soyez pas pressé, partez plus tôt, car il n'y a pas de personnes pressée elles ne sont qu'en retard !!!


Posté par: nico38
Posté le: Apr 01 2015 à 6:45pm
Message posté par nico38 nico38 a écrit:

ah il a l'air bien ce nouvel élément !

par contre quand je survol les vignettes : on voit les 2 vignettes à la fois au lieu d'une seule :
http://www.hostingpics.net/viewer.php?id=9951988699.png" rel="nofollow">

2. par defaut les numeros de pages sont bottom:-40px. Sur OE, si je vais dans la section de style "numeros de images" et que je mets distance bas 0px : ce n'est pas pris en compte (même en mettant !important) : sur oe pas dans un bloc de code

3. si on veut que le texte s'adapte en hauteur (si trop de texte ou écran plus petit) :
- en mettant auto en hauteur : le texte ne "reviens pas à la ligne"


par contre sur mon pc normal de bureau où oe est également installé : les images ne s'affichent pas dans le navigateur
(alors qu'en vérifiant sur firebug : les images sont bien là mais n'apparaissent pas)


Posté par: nico38
Posté le: Apr 03 2015 à 4:38pm
ça fait ça (c'est-à-dire rien) : http://www.youtube.com/watch?v=4GYTYzj1Mhg" rel="nofollow - https://www.youtube.com/watch?v=4GYTYzj1Mhg


Posté par: Bridet
Posté le: Apr 03 2015 à 5:01pm
dommage!


Posté par: nico38
Posté le: Apr 04 2015 à 4:24pm
ouai je collectionne les bugs


Posté par: Dmit OE
Posté le: Apr 04 2015 à 4:54pm
Bonjour,

Pouvez-vous publier en ligne et donner le lien?

Avez-vous enregistre la page avant previsualiser?

Avez-vous d'autres scripts sur la page qui peuvent casser JavaScript?


Posté par: nico38
Posté le: Apr 05 2015 à 8:38pm
voici un exemple sur une http://www.lashermes.com/dossier-test/Page.htm" rel="nofollow - page vierge

(j'ai mis le slide dans un fond orange


Posté par: Dmit OE
Posté le: Apr 06 2015 à 9:29pm
Dans ce cas precis, il y a une erreur qui ressurgit s'il n'y a qu'une seule image dans la liste. Ajoutez au moins 1 de plus et reessayez. Je note le bug.


Posté par: nico38
Posté le: Apr 07 2015 à 8:40pm
Alors ça a marché en ajoutant une image mais il y a bug quand même :
je suis du coup allé sur un autre projet :
j'ai mis une galerie.

- sur la page d'accueil de mon site : la gallerie n'apparait pas
- si je colle cette meme gallerie sur une autre page : elle s'affiche
(la gallerie n'a pas de class perso)

http://www.hostingpics.net/viewer.php?id=18522621bg.png" rel="nofollow">


Posté par: nico38
Posté le: Apr 07 2015 à 9:11pm
je viens de voir.
C'est un problème avec un bloc de code que j'ai positionné pour un slide wowslider :
<link rel="stylesheet" type="text/css" href="engine1/style.css" />
<script type="text/javascript" src="engine1/jquery.js"></script>


si je le désactive : le slide de OE marche


Posté par: MicroVinc
Posté le: Apr 07 2015 à 9:25pm
Il ne faut pas pointer jquery.js car il est déjà présent avec OE et rentre en conflit...

-------------
-Éléments pour OpenElement : https://goo.gl/Wq3Cpp" rel="nofollow - ICI
-Tutoriels pour OpenElement : https://goo.gl/NdpS1i" rel="nofollow - ICI


La Bretagne, un État dans l'État


Posté par: Maurice306
Posté le: Apr 08 2015 à 10:37am
Message posté par nico38 nico38 a écrit:

je viens de voir.
C'est un problème avec un bloc de code que j'ai positionné pour un slide wowslider :
<link rel="stylesheet" type="text/css" href="engine1/style.css" />
<script type="text/javascript" src="engine1/jquery.js"></script>

si je le désactive : le slide de OE marche

Bonjour à tous,

J'avais le même PB dans mes essais, et en suivant les conseils de MicroVinc j'ai supprimé le script en bleu et tout est rentré dans l'ordre 


-------------
La vie est belle !!!....., elle est comme chacun se la fait. Ne soyez pas pressé, partez plus tôt, car il n'y a pas de personnes pressée elles ne sont qu'en retard !!!


Posté par: Maurice306
Posté le: Apr 08 2015 à 3:26pm
Bonjour,

Je teste le SkitterSlider, j'ai mis des images assez grandes mais en prévisualisation elles sont assez réduites et je ne trouve pas comment modifier les dimensions du Slider, je pense que les images s'adaptent à son format.

Cordialement


-------------
La vie est belle !!!....., elle est comme chacun se la fait. Ne soyez pas pressé, partez plus tôt, car il n'y a pas de personnes pressée elles ne sont qu'en retard !!!


Posté par: Dmit OE
Posté le: Apr 08 2015 à 3:51pm
Vous configurez la taille comme pour n'importe quel element. Par exemple, mettez le slider dans un Panneau d'elements, en 100% largeur et hauteur, et le Panneau peut lui aussi avoir la taille en %, 100% si besoin.


Posté par: Maurice306
Posté le: Apr 08 2015 à 6:17pm
J'ai mis la page en responsive à 100%, un Panneau d'élément à 100% en relative, le Skitter  à 200px de HAUT et 800PX DE LARGE, les images font au mini 1020px x 616px . 

j'ai compris que c'est en redimensionnant que les images s'adaptent, elles ne s'adaptent pas à la hauteur et à la largeur du slider, il faudrait leur donner le format avant de les inclure.

En ce qui est du responsive j'ai bataillé mais c'est bon, il faut aussi adapter la dimension hauteur et largeur en proportion du format des images, car si la dimension en largeur et supérieure au rapport initial, le slider ne vas pas contre le bord gauche.


-------------
La vie est belle !!!....., elle est comme chacun se la fait. Ne soyez pas pressé, partez plus tôt, car il n'y a pas de personnes pressée elles ne sont qu'en retard !!!


Posté par: Maurice306
Posté le: Apr 08 2015 à 6:28pm
Par contre je tente de le faire monter tout en haut de la page, mais il reste toujours à quelques px du haut, même en positionnant le Panneau d'élément à 0px du haut

-------------
La vie est belle !!!....., elle est comme chacun se la fait. Ne soyez pas pressé, partez plus tôt, car il n'y a pas de personnes pressée elles ne sont qu'en retard !!!


Posté par: Larsene
Posté le: Apr 08 2015 à 7:12pm
Message posté par Maurice306 Maurice306 a écrit:

J'ai mis la page en responsive à 100%, un Panneau d'élément à 100% en relative, le Skitter  à 200px de HAUT et 800PX DE LARGE, les images font au mini 1020px x 616px . 

j'ai compris que c'est en redimensionnant que les images s'adaptent, elles ne s'adaptent pas à la hauteur et à la largeur du slider, il faudrait leur donner le format avant de les inclure.

En ce qui est du responsive j'ai bataillé mais c'est bon, il faut aussi adapter la dimension hauteur et largeur en proportion du format des images, car si la dimension en largeur et supérieure au rapport initial, le slider ne vas pas contre le bord gauche.


Heu, sérieusement ??!!

Évidemment qu'il faut adapter les images au format d'affichage sur le site !! Elles devraient être toutes exactement au même (et bon) format !

Quand on fait un site, on part en général d'une maquette ! faite avec Photoshop pour les plus riches, Gimp, Paint.net, etc. pour les autres. Vous connaissez ainsi exactement le format que va occuper le slider sur la page et créez ainsi vos images en conséquence !

Je comprends mieux l'intérêt de WOWSlider ! il essaie donc de sauver les meubles !


Posté par: Dmit OE
Posté le: Apr 08 2015 à 9:17pm
Normalement les images doivent s'adapter et se centrer meme si le rapport largeur-hauter ne correspond pas..


Posté par: nico38
Posté le: Apr 11 2015 à 8:01pm
Moi j'ai un phénomène paranormal.

j'ai un slider de 450px de large, dedans il y a 5 images.

- Si je mets ma deuxième image qui fait 300px de large (image + titre + lien) sur la deuxième ligne : toutes les images ne remplissent pas le slide : elles font 392px de large au lieu de 449.
- Si je la met en 3eme position : toutes les images remplissent le slide. ça marche. Smile


Posté par: nico38
Posté le: Apr 14 2015 à 12:12pm
d'ailleurs j'ai un bug.

Si on clic sur les images du slider qui renvoient à un lien : ça ne marche pas...

La premiere image il y a la possibilité de cliqué, mais dès que le slide passe à une autre image ça ne marche plus (idem pour la premiere image qui pourtant marchait)


Posté par: nico38
Posté le: Apr 14 2015 à 12:34pm
pour info voici quand ça marche et quand ça marche pas (quand ça marche c'est en allant sur examiner l'élément et que j'attends Stern Smile)
http://www.hostingpics.net/viewer.php?id=414161Sanstitre2.png" rel="nofollow">


Posté par: nico38
Posté le: Apr 14 2015 à 12:41pm
du cou en attendant je mets :
.box_clone {
  display: none !important;
}


Posté par: ridp
Posté le: Apr 20 2015 à 10:13pm
bonsoir,
j'aimerai savoir si on peut avoir des images qui occupent tout l'écran (peu importe leurs tailles)
pour info, je suis avec la charte responsive

merci


Posté par: Bridet
Posté le: Apr 21 2015 à 7:40am
oui : plus d'éléments -->  fond de page dynamique


Posté par: ridp
Posté le: Apr 21 2015 à 6:52pm
bonsoir,
je voulais dire avec skitter slider

merci


Posté par: Dmit OE
Posté le: Apr 22 2015 à 7:53am
Bonjour,

C'est prevu dans le script d'origine, mais ca ne m'a pas paru fiable, je pense pas que vous pouvez l'utiliser. Effectivement Fond de page dynamique est mieux adapté.


Posté par: ridp
Posté le: Apr 22 2015 à 11:52am
bonjour,
alors nouvelle question, je voudrais avoir cette fonction sur chaque rsection et de façon indépendante.

merci


Posté par: Bridet
Posté le: Apr 22 2015 à 2:58pm
moi aussi :-DDD !


Posté par: Dmit OE
Posté le: Apr 22 2015 à 5:12pm
Ce que vous pouvez faire, c'est inserer le Skitter dans une section mais directement dans le panneau externe, pas dans le panneau du contenu; mettre Largeur et Hauteur a 100%, ca peut marcher. Mais les images ne rempliront pas complement le conteneur, ils seront mis pour rentrer a l'interieur selon ses proportions. Je vais regarder pour ajouter l'option equivalent au Arriere plan->Taille "cover" dans Styles->Personnalisation, ca ne doit pasetre dur, juste manque du temps.


Posté par: Bridet
Posté le: Apr 22 2015 à 5:27pm
Merci D mit, car effectivement ce qu'on souhaite c'est que l'image remplisse l'écran et s'adapte, ce serait un gros plus pour OE mais chi va piano, va sano ! Ménage-toi! Va jouer avec ton fils, c'est mamy qui le dit ;-)!


Posté par: ridp
Posté le: Apr 22 2015 à 7:33pm
D'avance merci


Posté par: Dmit OE
Posté le: Apr 22 2015 à 8:28pm
Je ne sais pas du tout quand ce sera fait.. Je peux essayer de republier l'element dans quelques semaines.


Posté par: Maurice306
Posté le: Apr 23 2015 à 1:41pm
Message posté par Bridet Bridet a écrit:

"chi va piano, va sano" c'est mamy qui le dit

Tien les Mamy Belges parlent l'Italien LOL, T'es tu penché sur le responsive de Larsene, j'ai fait http://leucateportloc.free.fr" rel="nofollow - un de mes site qui est un bon compromis ! 


-------------
La vie est belle !!!....., elle est comme chacun se la fait. Ne soyez pas pressé, partez plus tôt, car il n'y a pas de personnes pressée elles ne sont qu'en retard !!!


Posté par: Bridet
Posté le: Apr 23 2015 à 4:49pm
Les belges parlent plus de langues que les français, pas difficile me diras-tu!
Je tiens quand même à préciser, même si je me suis traitée de mamy moi-même, que j'ai sans doute l'âge d'être la mère de Dmit mais pas la grand-mère ;-)!

Sinon, j'ai mené à terme mon site responsive validé par G et il ne manquerait que la possibilité de mettre deux sections (et non qu'une seule) en diaporama full screen pour faire mon bonheur, je ne vais pas faire un troisième site sur le même thème! D'ailleurs quand je vois tous les échanges de codes sophistiqués, je ne comprends pas pourquoi c'est si compliqué à apporter comme amélioration (mais comme je n'y connais rien).

Je compte refaire mon site professionnel un de ces quatre et sans doute avec le modèle Larsène mais un mix entre chouettes et abeilles.



Posté par: Maurice306
Posté le: Apr 23 2015 à 6:21pm
Du travail en perspective ! Bon courage Clap

-------------
La vie est belle !!!....., elle est comme chacun se la fait. Ne soyez pas pressé, partez plus tôt, car il n'y a pas de personnes pressée elles ne sont qu'en retard !!!


Posté par: nico38
Posté le: Apr 29 2015 à 12:24am
le slide est en 100% largeur pour qu'il s'adapte au écrans : mais quand l'écran est plus petit les images ne prennent pas tout le fond (comme un background cover).  y a-t-il moyen pour que les images soient "fullscreen" dans le slide quand l'écran impose une réduction de la largeur du slide ?


Posté par: Dmit OE
Posté le: Apr 29 2015 à 10:16am
Je prevois d'ajouter cette possibilite prochainnement (si j'ai bien compris la demande).


Posté par: nico38
Posté le: Apr 29 2015 à 10:34am
oui en gros ça fait ça sur mobile au lieu que l'image remplisse entièrement le slide
http://www.hostingpics.net/viewer.php?id=18110048dm.png" rel="nofollow">

(ici la largeur est 100% mais la hauteur est définie parce qu'il me semble qu'on ne peut pas garder le ratio d'origine si le slide se réduit, donc je cherche  ce qu'au moins les images restent "fullscreen" dans le diaporama)


Posté par: Dmit OE
Posté le: Apr 29 2015 à 10:40am
Oui je pense le faire, ca ne doit pas etre dur.


Posté par: Dmit OE
Posté le: Apr 29 2015 à 10:42am
P.S. On peut garder le ratio si on met le slider en 100% taille dans un Panneau d'elements et specifie le rapport largeur-hauteur pour ce panneau.


Posté par: nico38
Posté le: Apr 29 2015 à 11:00am
ah oui c'est vrai j'vais faire ça en attendant. On va finir par créer un forum "ratio élément" lol


Posté par: nico38
Posté le: May 09 2015 à 12:14am
je viens de voir qu'il n'y a pas d'attribut alt aux image du slider. Il faudrait peut etre que le titre qu'on entre pour chaque image corresponde aussi à l'alt.


Posté par: Dmit OE
Posté le: May 11 2015 à 9:33am
Bonjour,

Etrange, je vais verifier.


Posté par: FabL
Posté le: Jun 12 2015 à 6:28am
Bonjour,
Quand je clic sur le lien du slider, j'ai une fenêtre blanche qui s'ouvre et rien d'autre . Est ce normal ?
Merci


Posté par: Dmit OE
Posté le: Jun 12 2015 à 9:40am
Ca telecharge le fichier DLL, trouvez-le dans le dossier Telechargements (Downloads).


Posté par: imothep85
Posté le: Jun 28 2015 à 1:13pm
comment faire pour que skitter s'adapte a toutes les résolutions? quand je reduis la taille de mon browser il ne s'adapte pas :s

-------------
http://mattepainting.be/


Posté par: Dmit OE
Posté le: Jun 29 2015 à 9:01am
Il faut mettre sa taille - Largeur, Largeur max etc. - en %. Pour preserver le rapport largeur/hauteur, il faut le mettre dans un Panneau d'elements pour qu'il occupe 100% largeur et hauteur, et pour le Panneau, utiliser la propriete pour fixer le rapport - lesiz attentivement cette discussion


Posté par: imothep85
Posté le: Jul 12 2015 à 11:39am
la derniere version ne respecte pas l'ordre des images, jai mis 16 images, quand je clicque sur l'un des thumbnails au hasard, ben il affiche une autre image.

Il serait TRES utile d'ajouter une fonction "DOSSIER" ou skitter slider aficherait son contenu, plutot que de devoir ajouter des images 1 par une.
j'ai 10 dossier avec 100 images chacunes.....
des fois je prends jusqua 10.000 photos en un jour.....on imagine le problemme tres facilemment!



-------------
http://mattepainting.be/


Posté par: brolysan
Posté le: Jul 12 2015 à 11:44am
Message posté par imothep85 imothep85 a écrit:

la derniere version ne respecte pas l'ordre des images, jai mis 16 images, quand je clicque sur l'un des thumbnails au hasard, ben il affiche une autre image.

Il serait TRES utile d'ajouter une fonction "DOSSIER" ou skitter slider aficherait son contenu, plutot que de devoir ajouter des images 1 par une.
j'ai 10 dossier avec 100 images chacunes.....
des fois je prends jusqua 10.000 photos en un jour.....on imagine le problemme tres facilemment!


je t'ai répondu sur ton autre topic Wink. Evites svp les doublons, ou fermes l'autre topic, pour éviter tout problème.
Merci


Posté par: imothep85
Posté le: Jul 15 2015 à 8:15pm
comme je le disais "la derniere version ne respecte pas l'ordre des images, jai mis 16 images, quand je clicque sur l'un des thumbnails au hasard, ben il affiche une autre image."

bon a mon avis ca doit aller dans la section BUG!!!!


-------------
http://mattepainting.be/


Posté par: Bridet
Posté le: Jul 16 2015 à 7:55am
C'est peut-être normal mais si je mets trois images de tailles différentes dans le diapo, ce dernier s'adapte à la première et déforme les suivantes en conséquence.
Sur cette page http://architecte.de-troyer.be/construire.htm, on voit que la deuxième photo est étirée, si je la mets en premier lieu, le diapo l'affichera correctement et les deux autres seront "ratatinées" en largeur.
La fonction responsive fonctionne cependant (mais en ne respectant toujours pas le ration original de la deuxième photo). Le mode couvrir ne convient pas (ne prend que des parties de photos).
Dois-je absolument avoir toutes des images de même taille ou y a-t-il une astuce?

@ imothep : je confirme qu'il y a un problème avec les tumbnails qui n'appellent pas les bonnes images, en automatique l'ordre est respecté.


Posté par: Dmit OE
Posté le: Jul 16 2015 à 8:41am
Skitter Slider n'est pas bien adapte aux images de la taille differente..


Posté par: Bridet
Posté le: Jul 16 2015 à 8:43am
Ah, zut...


Posté par: Dmit OE
Posté le: Jul 31 2015 à 2:40pm
Bonjour,

Je viens d'ajouter quelques corrections concernant des soucis signalés ci-dessus, veuillez consulter le premier post de ce sujet pour le nouveau lien de téléchargement.

Cordialement
D


Posté par: Bridet
Posté le: Aug 01 2015 à 8:50am
Ca marche! Il ne reste plus qu'à ce qu'on puisse mettre des photos avec des tailles différents (en autorisant des bords transparents si photo plus petite que la plus grande?)


Posté par: Dmit OE
Posté le: Aug 01 2015 à 8:57am
Ce serait difficile. En revanche, on peut ajouter les bords transparents dans un editeur graphique pour obtenir le meme rapport largeur/hauteur pour tous les images)


Posté par: Bridet
Posté le: Aug 01 2015 à 9:25am
oui bien sûr, juste qu'il faut le faire ;-) (ouvrir le fichier, modifier, enregistrer) , ce serait chouette si c'était une option :-p


Posté par: xplorer
Posté le: Sep 08 2015 à 11:51pm
bonjour !
 
à tout hasard, question bête mais ... je n'ai pas compris comment installer le plugin skitter ( j'ai bien téléchargé un dossier sur le site de skitter mais je ne vois pas oû le mettre .. ) , et je vois aussi à la page "instal" de skitter, du code, mais j'imagine qu'il faut l'avoir installé avant ..
( d'ailleurs, même pour vegas, je n'ai pas compris encore comment faire )
 
mais ça a l'air bien comme plugin ! je cherchais même encore plus simple que ça, mais customisable, pour faire exactement la même chose : image qui passe à une autre en cliquant dessus, et avec une série de chiffres en dessous pour changer d'images d'une autre manière. et même, rajouter une petite icône permettant d'avoir une version plus grande en pop up de l'image en cours de visionnage.
 
http://www.jma.it/jm-architecture-jesolo-lido-pool-villa.html" rel="nofollow - http://www.jma.it/jm-architecture-jesolo-lido-pool-villa.html
 
Merci !


Posté par: nico38
Posté le: Sep 09 2015 à 12:00am
je vous l'ai dit ici :http://forum.openelement.com/fr/forum_posts.asp?TID=21371&PID=135427

il faut ensuite réouvrir le projet ou réouvrir OE, l'élément apparaitra pour le glisser/deposer


-------------
Un lien vers ton site tu enverras | Problème d'affichage ? ---> CTRL+F5 | Couleur des liens --> "Styles des liens"


Posté par: xplorer
Posté le: Sep 09 2015 à 12:05am
Message posté par nico38 nico38 a écrit:

je vous l'ai dit ici :http://forum.openelement.com/fr/forum_posts.asp?TID=21371&PID=135427

il faut ensuite réouvrir le projet ou réouvrir OE, l'élément apparaitra pour le glisser/deposer
 
oui c'est vrai, et j'avais essayé, le dll est bien dans common mais je ne le vois pas apparaître dans les éléments média.
sur le site j'ai vu qu'il y avait une autre forme d'installation alors ..
 
edit edit , mais oui .... c'est dans element de common. vous m'aviez écrit autre chose , vous ne vous souveniez plus dans quel sens : element / common ou l'inverse, et moi bêtement je n'ai pas cherché plus loin, j'avais mal compris, je vais réessayer ça devrait marcher ! :)


Posté par: nico38
Posté le: Sep 09 2015 à 12:06am
le dll ne doit pas etre dans Common mais dans Elements (skitter est un élément)

en plus l'explication était dans la page de téléchargement : http://forum.openelement.com/fr/forum_posts.asp?TID=20526&title=nouveau-el-skitter-slider-images-testez-svp

c'est obligé que ça marche. Sinon ça veut dire que vous avez découvert une faille spatio-temporelle.


-------------
Un lien vers ton site tu enverras | Problème d'affichage ? ---> CTRL+F5 | Couleur des liens --> "Styles des liens"


Posté par: xplorer
Posté le: Sep 09 2015 à 12:11am
ça marche, c'était juste un malentendu, encore merci.
 
pour choisir le mode de visionage, je suppose qu'il faut rentrer dans le code, pour définir la version qu'on préfère, je vais voir si j'y arrive, bon exercice ça.


Posté par: nico38
Posté le: Sep 09 2015 à 12:12am
skitter est un élément comme les autres, sa configuration se fait dans Propriétés, y a pas besoin d'entrer dans du code (sauf si on veut quelque chose de très précis)


-------------
Un lien vers ton site tu enverras | Problème d'affichage ? ---> CTRL+F5 | Couleur des liens --> "Styles des liens"


Posté par: xplorer
Posté le: Sep 09 2015 à 12:21am
très belles fonctions, bravo !
je vais voir si je peux configurer les petits points de la version minimalist , en cases ayant un chiffre à l'intérieur.
le changement d'images en mode fade me va très bien.
je vais voir si on peut le faire sans animation automatique : juste un click de la souris pour passer à une autre. et d'autres détails.
 
mais il se forme une barre noire en dessous de chaque image, après une seconde.
 
bon, ça demande d'explorer ça avant de poser des questions. encore merci


Posté par: xplorer
Posté le: Sep 09 2015 à 12:34am
c'est vraiment super comme élément.
 
je me demande quand même, mais je ne pense pas après avoir joué un peu avec , si on peut customiser
les cases de chiffres, ou les points : les disposer manuellement oû on les souhaite, avec un style personnel comme par exemple des icônes jpeg, ou des chiffres stylisés, encadrés ...
 
Et si on peut activer le changement d'images par un click sur l'image même.
 
Egalement, si l'on peut affecter une icône du style qu'on veut, qui lorsqu'elle est cliquée, permettrait d'ouvrir une fenêtre pop up, version plus grande ( et définie en taile, style .. ) de l'image de base.
 
merci, et désolé pour toutes ces questions de débutant.


Posté par: Hobby001
Posté le: Sep 09 2015 à 1:35am
Comme tous les éléments proposés par OE, ce qui est paramétrable facilement l'est via le panneau des propriétés a droite de l'écran.  

Prenez le temps d'apprendre avec les éléments simples comme un panneau d'éléments avant de vous aventurer dans un élément complexe comme celui-ci.

Si l'élément ne vous satisfait pas, vous devrez apprendre à maîtriser la programmation avant de vous lancer dans l'édition d'éléments existants.






-------------
https://www.denislafrance.net" rel="nofollow - Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.


Posté par: xplorer
Posté le: Sep 09 2015 à 1:55am
ah si si, il me satisfait, et je pourrais m'en contenter, mais je réfléchissais à voix haute à des fonctions qui m'intéressaient initialement.
Mais je m'accroche à open élément tous les jours ces temps-ci, pour apprendre. il y a des périodes de "dévérouillage" ... qui ouvrent des horizons.  mais ... on tâtonne encore.


Posté par: Bridet
Posté le: Sep 09 2015 à 7:44am
Egalement, si l'on peut affecter une icône du style qu'on veut, qui lorsqu'elle est cliquée, permettrait d'ouvrir une fenêtre pop up, version plus grande ( et définie en taile, style .. ) de l'image de base.

C'est l'élément zoom d'image.


Posté par: xplorer
Posté le: Sep 09 2015 à 12:43pm
merci, oui il est bien cet élément zoom, mais je doute de pouvoir l'appliquer aux images skitter, et de pouvoir disposer une icône "zoom" là oû je le souhaite, et customiser les fonctions du zoom, mais ça viendra, plus tard j'imagine quand je comprendrai mieux le code.
 
dans l'absolu, est-ce qu'on peut transformer du code qui donne une fonction, en plugin visible dans les éléments OE ? si OE marche comme ça les possibilités sont sans fin ! tellement génial cet open element .. j'adore.


Posté par: Hobby001
Posté le: Sep 09 2015 à 12:56pm
La philosophie derrière Skitter Slider:  http://www.skitter-slider.net" rel="nofollow - http://www.skitter-slider.net  c'est d'en faire l'élément important de votre page WEB.  Ce sera celui qui captera toute l'attention du visiteur pendant quelques secondes.  Si c'est réussi, le visiteur y passera même plus d'une minute.  Donc c'est déjà zoomé.

L'élément zoom d'images permet d'afficher une bonne quantité de miniatures et de les zoomer sur demande.  En prime le zoom sert de carrousel manuel pour voir toutes les images.



-------------
https://www.denislafrance.net" rel="nofollow - Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.


Posté par: xplorer
Posté le: Sep 09 2015 à 1:12pm
oui je comprends bien, mais je continue de chercher pour me rapprocher encore plus de ce que je souhaite faire. Un petit peu différent de ces possibilités.
 
mais s'il existe un dll de skitter, pour open element, je suppose qu'on peut reproduire dans l'absolu ce principe en créant des dll de fonctions venant de différents codes, et les retrouver dans la liste des éléments, ou je me trompe ? si par la suite je pourrai me façonner mes fonctions préférées à partir de code , et les "convertir" en plugins que je retrouverai à chaque ouverture d'OE , dans les éléments, ça serait génial :)


Posté par: brolysan
Posté le: Sep 09 2015 à 2:43pm
Message posté par xplorer xplorer a écrit:

oui je comprends bien, mais je continue de chercher pour me rapprocher encore plus de ce que je souhaite faire. Un petit peu différent de ces possibilités.
 
mais s'il existe un dll de skitter, pour open element, je suppose qu'on peut reproduire dans l'absolu ce principe en créant des dll de fonctions venant de différents codes, et les retrouver dans la liste des éléments, ou je me trompe ? si par la suite je pourrai me façonner mes fonctions préférées à partir de code , et les "convertir" en plugins que je retrouverai à chaque ouverture d'OE , dans les éléments, ça serait génial :)

y a plus qu'a tester l'éditeur d'éléments dans ce cas là. Wink


-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: xplorer
Posté le: Sep 09 2015 à 3:09pm
effectivement ! :) 
j'espère juste que ça permet de créer de nouveaux éléments à partir de codes trouvés sur internet, ou après avoir modifié un élément ou plugin d'OE. Eléments qu'on pourrait retrouver dans la liste d'éléments à chaque ouverture d'OE.
 
mais je vais déjà apprendre à déposer du code comme dans les tutos de larsène, et rendre un site responsive, ça sera déjà un grand pas ;)


Posté par: Dmit OE
Posté le: Feb 10 2016 à 11:00am
Bonjour,

J'ai mis a jour le lien dans le premier post, pour ceux qui utilisent OEGuideline pour ne plus avoir des erreurs dans le rapport.


Posté par: Miper
Posté le: Mar 25 2016 à 8:54am
Bonjour,
Je fais suite à un précédent post concernant un carrousel cliquable, Skitter, que je viens de découvrir suite à la réponse de Dmit remplit parfaitement cette fonction. Mais je ne parviens pas à changer les couleurs des boutons et/ou des numéros d'images... même en passant par la personnalisation du style...j'ai loupé quelque chose ?
merci


Posté par: Dmit OE
Posté le: Mar 25 2016 à 9:38am
Je viens de faire le test.

1) Certains couleurs peuvent etre modifies, par exemple la couleur de fond ou de text des boutons-numeros d'images, mais dans ce cas le style "active" se perd (on ne voit plus l'image selectionnée). Pour les boutons avant/arriere, on peut changer la couleur de fond mais il y a des images de fond qui definissent la couleur; vous povuez trouver ces images dans dossier du projet (Projet->Autre->Ouvrir le dossier du projet) \WEFiles\EG\EG_9aa5ea01\ResImg, mais attention, l'element peut les reecrire reguilierement donc si vous les modifiez gardez la modification quelque part pour la remettre en place si besoin. 

Sinon il faut modifier l'element lui-meme - Elements->Creer pour ouvrir l'Editeur d'Elements, on peut modifier le code CSS dans Scripts etc.

Encore sinon, on peut regarder dans un navigateur les styles et la structure HTML (clic-droit->Inspecter) et faire un Bloc de Code Source type CSS avec les styles necessaires.


Posté par: Miper
Posté le: Mar 25 2016 à 9:57am
Merci Dmit pour cette réactivité et la réponse hyper complète
Je test tout ça...


Posté par: nico95
Posté le: Dec 28 2016 à 10:32am
Bonjour à tous,

J'ai un soucis avec le slider. Lorsque j'intègre des images, elles ne s'affichent dans le navigateur que si je clique sur un des point situé en dessous de cet élément. Donc lorsqu'on arrive sur le site, ça reste blanc (couleur du fond du site).
Pour info, j'ai mis en lecture automatique et je n'affiche que les points.
La taille du slider est 500px de haut et 100% en largeur. J'ai activé le mode couvrir".
Les images que j'ai intégré font toutes la même taille et le site est responsive.
Je n'arrive pas à résoudre ce poblème. Pourriez-vous m'aider svp ?
Merci par avance.


Posté par: Dmit OE
Posté le: Dec 28 2016 à 10:58am
Bonjour,

Come d'habitude, il faudra que vous publiez le site quelque part (peut-etre dans un sous-dossier temporaire, avec Projet->Export dans un dossier + FileZilla) et donnez le lien.


Posté par: nico95
Posté le: Dec 28 2016 à 11:05am
Bonjour Dmit OE,

Merci pour votre intérêt. Le site est déjà en ligne mais sans cette modif que je souhaite apporter car ça ne fonctionne pas (ou mal).
Mon site est le suivant : www.coeurdemariage.fr



Posté par: brolysan
Posté le: Dec 28 2016 à 11:26am
pas mal ton site, sympa même je dirais. Thumbs Up

-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: nico95
Posté le: Dec 28 2016 à 11:28am
J'ai mis en ligne le slider sur la page page "partenaires" que vous trouverez dans le footer dans la section "infos pratiques" pour que vous puissiez voir le problème que je rencontre.


Posté par: nico95
Posté le: Dec 28 2016 à 11:31am
Merci pour le compliment brolysan Smile


Posté par: Dmit OE
Posté le: Dec 28 2016 à 12:15pm
Il faut enlever de vos Blocs de Code les references vers jQuery, comme celle-ci:

<script src=" https://ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js" rel="nofollow - https://ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js " type="text/javascript">

Il y a deja jQuery 1.10.2 integré par OE.

Si ca ne marche pas il y a d'autres choses a supprimer mais c'est moins evident. Je pense que ca suffira deja.


Posté par: nico95
Posté le: Dec 28 2016 à 1:18pm
J'ai supprimé cette ligne dans mon bloc de codes html mais c'est pire. Il ne sepasse plus rien et ça n'affiche plus rien non plus donc je pense que le problème ne doit pas venir de là.
Il faudrait explorer d'autres pistes.


Posté par: brolysan
Posté le: Dec 28 2016 à 1:59pm
bizarre alors, il nous faudrait votre projet pour que l'on regarde les blocs de code qui peuvent gêner.

-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: nico95
Posté le: Dec 28 2016 à 2:22pm
D'accord. Et comment dois-je procéder ?


Posté par: brolysan
Posté le: Dec 28 2016 à 3:05pm
Je viens de vous envoyer un MP pour la procédure. Wink

-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: Dmit OE
Posté le: Dec 28 2016 à 11:38pm
De toute facon vous ne devez pas avoir 2 references jQuery sur une page (meme si de fois ca peut marcher). Mais il faut peut-etre "nettoyer" mieux que cela. Sinon, il faut supprimer cette ligne et ensuite mettre cette mersion (1.7.2) dans Projet-Preferences-Expert-Version jQuery, s'il y a des soucis de compatibilite quelque part.


Posté par: Bridet
Posté le: Dec 29 2016 à 8:26am
Message posté par brolysan brolysan a écrit:

pas mal ton site, sympa même je dirais. Thumbs Up

Oui ! On a envie d'aller plus loin et je suis allée voir les costumes hommes, jolis mannequins Tongue !


-------------
http://accessit.be" rel="nofollow - Les Billets d'une Bobonne Bougonne - http://gite.vervoz.be" rel="nofollow - Gîte Le Vicus



Imprimer la Page | Close Window

Forum Software by Web Wiz Forums® version 10.18 - http://www.webwizforums.com
Copyright ©2001-2014 Web Wiz Ltd. - http://www.webwiz.co.uk