Antivirus offre spéciale - jusqu'à 60 % de réduction avec openElement !
Accueil Forum Accueil Forum >

openElement

> OE dynamique - bases de données etc.
  Nouveaux messages Nouveaux messages Fil RSS  - RESOLU : Pb validation de COMPTE par Mail
  FAQ FAQ  Rechercher dans le Forum   Inscription Inscription  Connexion Connexion

RESOLU : Pb validation de COMPTE par Mail

 Répondre Répondre
Auteur
Message inverser le tri
Dmit OE allez vers le bas
Admin Group
Admin Group
Avatar

Depuis le: 31 Mai 2012
Status: Inactif
Points: 13998
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer Dmit OE Citer  RépondreRéponse Lien Direct à ce Post Sujet: RESOLU : Pb validation de COMPTE par Mail
    Envoyé : 12 Mar 2018 à 12:27
Ca oui
- Pourquoi faire simple si on peut faire compliqué? - C'est juste pour vous embêter
Haut de la page
Chantoune allez vers le bas
Senior Member
Senior Member
Avatar

Depuis le: 31 Jan 2013
Status: Inactif
Points: 171
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer Chantoune Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 11 Mar 2018 à 21:33
et bien voila j'ai trouvé mon erreur :TongueTongue

En fait dans le formulaire accessible depuis Projet/préférences dans l'onglet configuration

il faut renseigner  :

adresse du serveur, nom d'utilisateur et adresse URL du site et la il faut inscrire
https://mon domaine/SITE

par contre dans le répertoire par défaut il faut mettre /public_html/SITE

et ainsi l'email de validation renvoi bien un lien avec https://mondomaine/SITE/............connexion.....
et non https://mondomaine/public_html/SITE/.......connexion..... qui génère cette erreur 404
Haut de la page
Dmit OE allez vers le bas
Admin Group
Admin Group
Avatar

Depuis le: 31 Mai 2012
Status: Inactif
Points: 13998
Options des messages Options des messages   Thanks (1) Thanks(1)   Citer Dmit OE Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 11 Mar 2018 à 21:30
Bonjour,

C'est tres courant qu'il faut mettre le site dans public_html.

S'il y a un tel souci avec le Packs (ce qui est etrange), vous pouvez mettre la redirection par htacces, pour rediriger les domaine/public_html/site vers domaine/site. Regardez les tutos si c'est trop complique postez ici la question. C'est une redirection du genre 

RewriteRule ^/?public_html/(.*)$ /$1

il faut bien choisir l'emplacement de .htaccess et vois s'il faut le modifier dans OE ou manuellement
- Pourquoi faire simple si on peut faire compliqué? - C'est juste pour vous embêter
Haut de la page
Chantoune allez vers le bas
Senior Member
Senior Member
Avatar

Depuis le: 31 Jan 2013
Status: Inactif
Points: 171
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer Chantoune Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 11 Mar 2018 à 15:05
Bonjour,
j'ai fait des essais de création/modif... de compte sur ma machine locale après avoir implémenté le userPack et le sqlite : tout fonctionne comme souhaité avec l'emulateur de mail

MAIS Le serveur nous oblige a implémenter sur un répertoire "public_html"
 
J'ai donc mondomaine/public_html/SITE/....... alors qu'avant j'avais localhost/SITE/......

Pour accéder au site le "public_html" est transparent : il suffit de donner l'URL mondomaine/SITE/....

Désormais lorsque l'on crée un compte le mail d'activation reçu est mondomaine/public_html/SITE/............. qui donc provoque une erreur 404 quand on clique dessus

Comment modifié ceci : probablement dans la class_phpmailer.php ?
Merci pour votre aide attendue


Edité par Chantoune - 11 Mar 2018 à 21:35
Systeme window 10
open element version 57R9
Haut de la page
 Répondre Répondre
  Partagez ce sujet   

Aller au Forum Permissions du forum allez vers le bas

Forum Software by Web Wiz Forums® version 10.18
Copyright ©2001-2014 Web Wiz Ltd.

Cette page a été affichée en 0,031 secondes.
Acheter votre vélo en ligne