Print Page | Close Window

-SOLUTION- Folder Delete destroys links 1579

Printed From: Forum openElement
Category:

openElement


Forum Name: Error Reports
Forum Description: Submit an error report for our technical support.
URL: http://forum.openelement.com/fr/forum_posts.asp?TID=1242
Printed Date: 25 Mai 2019 at 19:55
Software Version: Web Wiz Forums 10.11 - http://www.webwizforums.com


Topic: -SOLUTION- Folder Delete destroys links 1579
Posted By: digizar
Subject: -SOLUTION- Folder Delete destroys links 1579
Date Posted: 04 Oct 2017 at 14:16
Condensed result after investigation:
Do not delete any folder

When I delete an (empty) folder in the Site Explorer (snap-1),
it screws up all links to pages located inside other folders.
But links to pages located in the 'root' appear ok.
Also, many random (not all) links to images inside pages are lost.

Regain ist possible if all pages (incl all layers) are manually loaded piece by piece and saved back again.
The missing images as such still exist as an empty/blank element, but have to be manually recovered piece by piece by re-assigning the (still existing) link to them.

A complete Export to Folder also reveals all missing *.htm files, though their *.css are created (snap-2).

For a huge project with several hundreds of pages and images that might be deadly.

I loaded the *.zip (some 110 MB) onto a server, and send you the access details as usual with PN.
Don't hurry, for  me it's ok, I learned my lesson, and so far I avoid that procedure; but to keep others away from the same trap, I submit this report.

snap-1


snap-2



-------------
___________________________________
Ask questions only if there is no answer yet.
https://digispics.com/_pers/resger2017.pdf



Replies:
Posted By: Dmit OE
Date Posted: 04 Oct 2017 at 15:14
Hi.

This looks bad. If you delete a non-empty folder, the effect is the same? Are ALL the links to pages are broken?


Posted By: digizar
Date Posted: 04 Oct 2017 at 17:27
1) If you delete a non-empty folder, the effect is the same?
Yes, I didn't check that yet, but now in the second round, the effect ist the same.
Addt'l info (condensed):
Deleting any page inside a folder ist ok.
Deleting any page in the 'root' is also ok.
It affects only the folders, w or w/o content (page(s)).


2) Are ALL the links to pages broken?
Yes, only the 'impressum' page (which is the last page -not a folder- in the project) is accessable through the HomePage link.
Means there is a difference:
An empty folder affects all links in the pages in sub-folders only.
But a folder with pages as content, if deleted, affects ALL pages.

Both versions do not show the *.html, but the *.css is created during Export to Folder.
In this case now the impressum.htm and impressum.css are created.
Also the Optimize does not help.
It is somehow confusing. No real grip on the cause.
The Database may be somehow corrupted, because the cumbersome manual re-creation solves the problem.
Just by reading the files with the editor and re-save them. So the links must still exist.
Is also true if several pages are loaded into the editor, and then being 'Saved All' in one bunch. That makes them 'valid' again.

Best thing is to re-install the oE. I'll give it a try, it's a remote chance.
And I'll report.
Did it and - nop, didn't help.
Deleting ANY folder ends in disaster.


-------------
___________________________________
Ask questions only if there is no answer yet.
https://digispics.com/_pers/resger2017.pdf


Posted By: Dmit OE
Date Posted: 04 Oct 2017 at 22:20
Ok, thank you for the report. If you have time, could you please try to:
- create a project,
- create a folder in Site Explorer (inside OE), 2 pages inside it, as well as several pages in the "root" (out of folders).
- Create links on homepage to all pages pages (in and out of folders).
- Delete the folder.
- Check what happens to Export and to links.


Posted By: digizar
Date Posted: 05 Oct 2017 at 17:21
Ok, thank you for the report. If you have time, could you please try to ...
Yes, will do and report here.

Did as requested, and report:
The same result, all links disabled with the wind.
So, therefore I strongly recommend not to delete any folder for the time being.

The correct sample source is:
http://microdigi.org/Saving_1_57_9_0_FolderTest.zip" rel="nofollow - http://microdigi.org/Saving_1_57_9_0_FolderTest.zip

Crash report file (shown this time), but may contain lots of superficial entries.
http://microdigi.org/foldertest_crashtext.txt" rel="nofollow - http://microdigi.org/foldertest_crashtext.txt

Process, as recommended:
created new project
created two folders
  the folder1 - created two pages inside
  the folder2 - empty
created two root pages
explicitely used BaseLayer for all of them
no favicon
established links (on HomePage) to alle pages, (and back to HomePage)
compiled and worked ok
-
deleted folder1
saved all, received crash report (in the background, not to be seen) -snap1-
compiled anway
missing *.htm for all pages (expcept index.htm)
NO Links at all, but the *.css were present -snap2-
On Export to Folder the result -snap3-


Snap1


snap2


snap3



-------------
___________________________________
Ask questions only if there is no answer yet.
https://digispics.com/_pers/resger2017.pdf


Posted By: Dmit OE
Date Posted: 06 Oct 2017 at 08:21
Thank you for reports, it should help to fix it for the next version


Posted By: digizar
Date Posted: 28 Mar 2018 at 21:03
Delete folders.
Any fix available on the table?
It's really nasty.


-------------
___________________________________
Ask questions only if there is no answer yet.
https://digispics.com/_pers/resger2017.pdf


Posted By: Dmit OE
Date Posted: 28 Mar 2018 at 23:52
Yes it's nasty, but unfortunately the fix is not yet there. We will post here when it's available.


Posted By: digizar
Date Posted: 14 Avr 2019 at 16:17
Crash on Folder Delete.
Well, after years I found a simple solution.
Do not remove the Folder(s) inside the OE Site Explorer; that crashes the databank of OE.
Remove the directory/folder directly from inside the local source folder (Standard File Manager).
Then (re)start OE - and it's gone. Clap

It is then mandatory to run the link checker,
and to verify links pointing to (some) pages of that removed folder.
Because the internal OE databank does/can not know that probably any link target page(s) disappeared.
Preferences ... Maintanance ... Rebuild pages and website link map (Execute).



-------------
___________________________________
Ask questions only if there is no answer yet.
https://digispics.com/_pers/resger2017.pdf



Print Page | Close Window

Forum Software by Web Wiz Forums® version 10.11 - http://www.webwizforums.com
Copyright ©2001-2012 Web Wiz Ltd. - http://www.webwiz.co.uk