BullGuard Antivirus Sale - 60% Off with openElement !
Forum openElement Homepage
Forum Home Forum Home >

openElement

> openElement General Discussion
  New Posts New Posts RSS Feed - Problem with Simple Modal Popup and WEPanel
  FAQ FAQ  Forum Search   Register Register  Login Login

Problem with Simple Modal Popup and WEPanel

 Post Reply Post Reply
Author
Message
oeforumuser View Drop Down
Newbie
Newbie


Joined: 18 Sep 2020
Location: Pennsylvania
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote oeforumuser Quote  Post ReplyReply Direct Link To This Post Topic: Problem with Simple Modal Popup and WEPanel
    Posted: 18 Sep 2020 at 20:49
I am having trouble using the Simple Modal Popup using the SENSWHITE template.

I am trying to put a popup in a WEPanel in the SENSWHITE template and do not see...



...the foreground and horizontal and vertical buttons. Instead I see...



Am I doing something wrong or is there a workaround for this?

I also tried putting the popup somewhere else and it pops up in that other location. I have put the trigger in the contact section and want the popup to work there. Since the template makes heavy use of WEPanel, I am having trouble creating a popup.

Cheers!!


Edited by oeforumuser - 19 Sep 2020 at 02:30
Back to Top
Hobby001 View Drop Down
Admin Group
Admin Group
Avatar

Joined: 05 Juin 2018
Location: Canada, Québec
Status: Offline
Points: 5179
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hobby001 Quote  Post ReplyReply Direct Link To This Post Posted: 21 Sep 2020 at 13:14
You can try this one


It pops up at page opening
Back to Top
oeforumuser View Drop Down
Newbie
Newbie


Joined: 18 Sep 2020
Location: Pennsylvania
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote oeforumuser Quote  Post ReplyReply Direct Link To This Post Posted: 24 Sep 2020 at 20:22
Thanks for your reply.

I am looking to create a pop-up using a photo of a phone as the trigger in the contact area that contains a legal notice and a JavaScript that creates and obfuscated tel: link. I have what I need for this.

I am doing this to help prevent professional scammers from calling. I am a landlord and we get all kinds of crazy calls that have nothing to do with actual inquiries.

I have been able to make the pop-up in other areas, however, since this template uses WEPanels throughout the page, I am unable to have a user click the phone image to trigger a pop-up where the user is on that page. Creating the pop-up in the contact WEPanel does not allow it to be a proper pop-up.

Is this an element that will allow this?

Cheers!!


Edited by oeforumuser - 24 Sep 2020 at 20:28
Back to Top
Hobby001 View Drop Down
Admin Group
Admin Group
Avatar

Joined: 05 Juin 2018
Location: Canada, Québec
Status: Offline
Points: 5179
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hobby001 Quote  Post ReplyReply Direct Link To This Post Posted: 24 Sep 2020 at 21:59
If you use an image element and link your javascript function, would it work for you?

Otherwise describe step by step the required process.  I'm still not sure to understand what you are trying to achieve.


Edited by Hobby001 - 25 Sep 2020 at 02:45
Back to Top
oeforumuser View Drop Down
Newbie
Newbie


Joined: 18 Sep 2020
Location: Pennsylvania
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote oeforumuser Quote  Post ReplyReply Direct Link To This Post Posted: 24 Sep 2020 at 23:30
When a user clicks the phone image, I want a simple pop-up that will have a legal disclaimer and a tel: link. The user would use the tel: link to call by cell phone or simply dial the number they see. I am using JS to create the tel: link and obfuscate the link from bots.

When I create a Simple Modal Popup outside of a WEPanel, it works but opens only where the Simple Modal Popup exists.

However, when I try to create a Simple Modal Popup inside of a WEPanel, I cannot select "foreground", "horizontal", and "vertical" buttons as they are not there. See example images in original post.

Because the template uses WEPanel exclusively throughout the template, I am not able to avoid using an existing WEPanel without surgery.

I generally code all my sites using a text editor or Atom, however, I s*ck at pretty. I am trying to use OE to help me with the overall look and feel of a few sites. (I am retired from the tech industry, however, I do generally know what I am doing still.)

I have played with OE on Linux in the past, however, it crashed a lot and I gave up. I am trying again on Windows. All seems well. Just trying to get through a few simple issues. This one is escaping me.

I was wondering if I am missing something in why I do not see the expected buttons or if there is a work-around. Otherwise, if surgery is needed, I may need help there too.

Thanks in advance.

Cheers!!
Back to Top
Hobby001 View Drop Down
Admin Group
Admin Group
Avatar

Joined: 05 Juin 2018
Location: Canada, Québec
Status: Offline
Points: 5179
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hobby001 Quote  Post ReplyReply Direct Link To This Post Posted: 24 Sep 2020 at 23:55
It's a mater of display relative or absolute

Look at this video: https://youtu.be/6toO45j_Esc
Back to Top
Hobby001 View Drop Down
Admin Group
Admin Group
Avatar

Joined: 05 Juin 2018
Location: Canada, Québec
Status: Offline
Points: 5179
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hobby001 Quote  Post ReplyReply Direct Link To This Post Posted: 24 Sep 2020 at 23:57
Take also a look at this one https://youtu.be/XoHckOdbK6c
Back to Top
Hobby001 View Drop Down
Admin Group
Admin Group
Avatar

Joined: 05 Juin 2018
Location: Canada, Québec
Status: Offline
Points: 5179
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hobby001 Quote  Post ReplyReply Direct Link To This Post Posted: 24 Sep 2020 at 23:59
You will also find valuable information here: https://forum.openelement.com/en/forum_posts.asp?TID=1678&title=video-tutorial-oe-157-r9

Edited by Hobby001 - 25 Sep 2020 at 02:45
Back to Top
digizar View Drop Down
Senior Member
Senior Member
Avatar

Joined: 30 Dec 2015
Location: Germany Frankf
Status: Offline
Points: 616
Post Options Post Options   Thanks (0) Thanks(0)   Quote digizar Quote  Post ReplyReply Direct Link To This Post Posted: 25 Sep 2020 at 00:40
Originally posted by oeforumuser oeforumuser wrote:

I have played with OE on Linux in the past, however, it crashed a lot and I gave up. I am trying again on Windows. All seems well. Just trying to get through a few simple issues. This one is escaping me.
OE ist not designed to work with Linux.
___________________________________
Ask questions only if there is no answer yet.
https://digispics.com/_pers/resger2017.pdf
Back to Top
oeforumuser View Drop Down
Newbie
Newbie


Joined: 18 Sep 2020
Location: Pennsylvania
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote oeforumuser Quote  Post ReplyReply Direct Link To This Post Posted: 25 Sep 2020 at 00:55
Small error. It was a long time ago...
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.11
Copyright ©2001-2012 Web Wiz Ltd.

This page was generated in 0,031 seconds.