Imprimer la Page | Close Window

Formulaire contact - Incompatibilité Yahoo/Gmail

Imprimé depuis: Forum openElement
Categorie:

openElement


Nom du Forum: Discussion générale openElement
Description du Forum: Discussion générale sur le logiciel
URL: http://forum.openelement.com/fr/forum_posts.asp?TID=23772
Date: 05 Juin 2020 à 02:33
Version logiciel: Web Wiz Forums 10.18 - http://www.webwizforums.com


Sujet: Formulaire contact - Incompatibilité Yahoo/Gmail
Posté par: Cyril12345
Sujet: Formulaire contact - Incompatibilité Yahoo/Gmail
Posté le: 23 Jan 2020 à 10:08
Bonjour,

J'ai mis en place un formulaire de contact sur mon site OE avec les champs Prénom/Nom, Email, Téléphone, Message... Tout fonctionne parfaitement bien,

sauf un point : lorsque le site est en ligne (hébergé chez OVH) et qu'une personne envoie un message depuis le formulaire avec une adresse en Yahoo (saisie dans le champ Email), ce message n'arrive pas dans ma boite de destination en gmail.
En revanche, si la boite de destination est différente de gmail (orange, sfr, ...), le message arrive.

Il s'agirait donc d'une incompatibilité (passagère ?) entre yahoo et gmail.

Y aurait-il quelque chose à paramétrer pour corriger cela ? Quelqu'un d'autre rencontre-t-il ce dysfonctionnement ?

Merci pour vos réponses Smile



Réponses:
Posté par: brolysan
Posté le: 23 Jan 2020 à 10:48
non, mais pensez à regarder dans votre boite spams plutôt... Wink

-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: Cyril12345
Posté le: 23 Jan 2020 à 11:11
Oui j'ai bien regardé dans les spams et rien du tout...

Il semble que le problème soit connu, car j'ai regardé sur Google ("gmail ne reçoit pas les mails yahoo") et plusieurs forum aborde le problème...

Y a t'il quelque chose à faire...?


Posté par: Hobby001
Posté le: 23 Jan 2020 à 13:29
Trouvez quelqu'un qui a une adresse yahoo et demandez lui de vous envoyer un mail directement sur votre adresse gmail.

Revenez nous avec le résultat.


-------------
Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.


Posté par: Cyril12345
Posté le: 23 Jan 2020 à 14:36
Bonjour Hobby, c'est exactement ce que j'ai fait. Et le message (venant d'une adresse yahoo) n'arrive pas.

Mais il n'y a même pas besoin de faire appel à quelqu'un. Il suffit juste de se rendre sur le formulaire et de mettre dans le champ Email une adresse en yahoo.fr, n'importe laquelle, même inventée (du type xxxx@yahoo.fr) et le message n'arrivera pas sur la boite gmail.
Si vous en avez la possibilité, faites un essai sur l'un de vos sites en mettant une adresse gmail en destinataire et en essayant d'envoyer un message avec une adresse yahoo... Vous verrez...


Posté par: brolysan
Posté le: 23 Jan 2020 à 14:45
donc vous confirmez que cela vient de gmail avec yahoo, donc il n'y a rien à faire au niveau d'Openelement.

-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: Cyril12345
Posté le: 23 Jan 2020 à 14:48
Mais effectivement depuis le début, je ne mets pas du tout OE en cause...

Je voulais juste savoir s'il existait une parade à cela, à programmer dans OE, mais apparemment non.

Et également informer la communauté OE, qui évoque régulièrement des soucis de réception des mails, que le problème peut venir des opérateurs entre eux, comme ici en l'occurrence entre Yahoo et Gmail...


Posté par: Cyril12345
Posté le: 23 Jan 2020 à 14:53
Une petite correction pour Hobby (j'ai répondu un peu vite) : oui les messages envoyés directement sur gmail depuis une adresse yahoo arrivent très bien !

Le problème se pose lorsque l'on passe par le formulaire du site OE


Posté par: Cyril12345
Posté le: 23 Jan 2020 à 14:57
C'est depuis le formulaire de contact du site OE que Gmail n'accepte pas les messages en provenance d'une adresse Yahoo...

J'ai trouvé sur internet un sujet qui évoque ce problème :
https://www.arobase.org/forums/viewtopic.php?t=27879" rel="nofollow - https://www.arobase.org/forums/viewtopic.php?t=27879


Posté par: Cyril12345
Posté le: 23 Jan 2020 à 15:21
Brolysan, pour illustrer le problème je viens de faire un essai avec le template Senswhite en version d'origine (c'est-à-dire sans avoir rien modifié), avec pour adresse email de réception une adresse en gmail...

Lorsque je le mets en ligne, et que j'utilise le formulaire :
- si je mets dans le champ email une adresse en autre chose que yahoo (en free.fr par exemple) le message arrive bien immédiatement sur l'adresse gmail
- si je mets dans le champ email du formulaire une adresse en xxx@yahoo.fr, le message n'arrive pas sur l'adresse gmail.

(Si je mets des adresses en copie dans le formulaire, autres qu'en yahoo), le message arrive également sur ces adresses en copie).


Posté par: Hobby001
Posté le: 23 Jan 2020 à 15:26
Selon le texte cité dans votre message:  https://www.arobase.org/forums/viewtopic.php?t=27879" rel="nofollow - https://www.arobase.org/forums/viewtopic.php?t=27879

C'est un choix de Yahoo et de Google.

C'est selon ce même texte à régler dans votre configuration mail sur Google


-------------
Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.


Posté par: Cyril12345
Posté le: 23 Jan 2020 à 15:36
Merci Hobby,

C'est donc dans les paramètres de gmail qu'il faut intervenir ?


Posté par: Hobby001
Posté le: 23 Jan 2020 à 16:24
Message posté par Cyril12345 Cyril12345 a écrit:

Merci Hobby,

C'est donc dans les paramètres de gmail qu'il faut intervenir ?

Là vous devrez faire des essais.  Je ne peux faire mieux.  Par contre l'article ne démontre pas que ça fonctionne.

Personnellement, mon hébergeur m'offre un service de courriel avec mes propres adresses je ferais un essai avec une de ces adresses pour voir si j'étais vous.

Je sais pertinemment que je peux configurer cette adresse dans un compte gmail pour les lire.


-------------
Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.


Posté par: Cyril12345
Posté le: 23 Jan 2020 à 17:51
Merci Hobby pour vos orientations Smile

Je vais voir ce que je peux faire.
Mais cette histoire de messages qui n'arrivent pas lorsqu'ils sont émis depuis un formulaire (dont les formulaires OE), de Yahoo à Gmail (et peut-être également dans d'autres configurations) est quand même un peu perturbante...

Merci en tout cas pour votre assistance !


Posté par: Hobby001
Posté le: 23 Jan 2020 à 18:04
Message posté par Cyril12345 Cyril12345 a écrit:

Merci Hobby pour vos orientations Smile

Je vais voir ce que je peux faire.
Mais cette histoire de messages qui n'arrivent pas lorsqu'ils sont émis depuis un formulaire (dont les formulaires OE), de Yahoo à Gmail (et peut-être également dans d'autres configurations) est quand même un peu perturbante...

Merci en tout cas pour votre assistance !

Si vous lisez bien l"article, il est clair que c'est valable pour tous les formulaires.  Qui plus est, cela risque de devenir une tendance.



-------------
Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.


Posté par: Hobby001
Posté le: 23 Jan 2020 à 18:13
Quand vous dites le champ email, voulez vous parler du email de l'expéditeur (le visiteur) dans la configuration de l'envoi?

Si c'est le cas, mettez-y une adresse Google ou une adresse dans votre domaine et récoltez l'adresse email via un champ séparé.

Ne la renseignez plus dans le champ.


-------------
Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.


Posté par: Cyril12345
Posté le: 23 Jan 2020 à 19:29
Une fois de plus je dois saluer la très bonne idée de Hobby001Smile

Dans la configuration de "l'Envoi par e-mail", j'ai donc mis :
Adresse e-mail de réception : l'adresse en gmail
Adresse e-mail de l'expéditeur : une adresse de mon nom de domaine (du type xxx@MonNomDeDomaine.com) (Alors que d'habitude, je mettais dans cette case l'Attribut Name du champ Email, ce qui semble-t-il était la cause du problème avec Yahoo).
Je récupère l'émail de l'expéditeur via un champ email classique (au côté des champs Nom, Téléphone et Message)

Et ça marche ! lorsque l'on envoie un message avec une adresse yahoo.fr ou yahoo.com depuis le formulaire à partir du site en ligne.
Je reçois à présent bien le message (expédié avec une adresse yahoo) sur l'adresse gmail (dans les messages normaux) et sur l'adresse de mon nom de domaine (cette fois dans les indésirables mais ce n'est pas grave)...

Un grand merci à Hobby001 (et à Brolysan) pour l'efficacité de vos propositions Smile Smile


Posté par: Hobby001
Posté le: 23 Jan 2020 à 21:01
@brolysan

J'ignore si c'est possible mais faudrait mettre à jour le tuto sur les formulaires avec cette info.




-------------
Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.


Posté par: NATURX
Posté le: 26 Mar 2020 à 15:49
Bonjour,
Mon site est hébergé chez Free et a été créé avec Open Element.
J'avais essayé cette fonctionnalité en novembre et il me semblait qu'il n'y avait pas trop de souci mais cela a changé apparemment du côté de chez Free...
Je confirme, après avoir bataillé et cherché pendant une journée... que la seule façon d'envoyer un mail avec l' Elément "Envoi par email" est de le paramétrer au niveau email comme ceci :
- email de réception avec un mail GMAIL
- email expéditeur avec le mail associé à votre site FREE
- le WEEMAIL est un élément d'information en provenance du formulaire OE transmis dans le mail formulaire de contact comme le par exemple
Par contre l'accusé de réception ne fonctionne pas du coup avec toutes les adresses.. du coup je ne l'ai pas mis en service
D'autre part sous l'onglet PROJET puis PREFERENCES, MISE EN LIGNE, CONFIGURATION le type de mail à paramétrer est bien MAIL (et non SENDMAIL, QMAIL ou SMTP)


Posté par: Hobby001
Posté le: 26 Mar 2020 à 16:15
Message posté par NATURX NATURX a écrit:

Bonjour,
Mon site est hébergé chez Free et a été créé avec Open Element.
J'avais essayé cette fonctionnalité en novembre et il me semblait qu'il n'y avait pas trop de souci mais cela a changé apparemment du côté de chez Free...

Cette situation ne vient pas de chez Free, ça vient du souci de protection par les différents services email comme gmail, hotmail etc

Si le courriel ne vient pas du serveur de l'adresse, il sera refusé.  Si votre site est toto.com le courriel doit provenir d'une adresse @toto.com  

Message posté par NATURX NATURX a écrit:

Je confirme, après avoir bataillé et cherché pendant une journée... que la seule façon d'envoyer un mail avec l' Elément "Envoi par email" est de le paramétrer au niveau email comme ceci :
- email de réception avec un mail GMAIL
- email expéditeur avec le mail associé à votre site FREE
- le WEEMAIL est un élément d'information en provenance du formulaire OE transmis dans le mail formulaire de contact comme le par exemple
Par contre l'accusé de réception ne fonctionne pas du coup avec toutes les adresses.. du coup je ne l'ai pas mis en service
D'autre part sous l'onglet PROJET puis PREFERENCES, MISE EN LIGNE, CONFIGURATION le type de mail à paramétrer est bien MAIL (et non SENDMAIL, QMAIL ou SMTP)


-------------
Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.


Posté par: NATURX
Posté le: 26 Mar 2020 à 16:36
Ok sur ta remarque par rapport au mail expéditeur si je suis cher x.free.fr l'email expéditeur doit être x@free.fr
Mais concernant l'email de réception j'ai essayé avec une adresse qui n'est pas en gmail.com par exemple y@orange.fr ou z@live.fr et dans ces cas là l'envoi ne fonctionne pas


Posté par: Hobby001
Posté le: 26 Mar 2020 à 17:09
Faites l'essai avec ce formulaire  https://denislafrance.net/Contact.htm" rel="nofollow - https://denislafrance.net/Contact.htm

Vous devriez recevoir un accusé de réception, revenez-moi par la suite


-------------
Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.


Posté par: NATURX
Posté le: 26 Mar 2020 à 17:23
L'accusé de réception fonctionne sur ce formulaire effectivement


Posté par: Hobby001
Posté le: 26 Mar 2020 à 17:43
Donc mon site:                          denislafrance.net
L'adresse de l'expéditeur:           noreply@denislafrance.net
L'adresse de réception:               mon adresse courriel personelle
L'adresse pour accusé réception: un champ de saisie de texte





-------------
Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.


Posté par: NATURX
Posté le: 26 Mar 2020 à 18:10
Je pensais que l'adresse pour accusé de réception faisait partie d'un envoi automatique d'Open Element... Tu dis que l'adresse pour accusé de réception est un champ de saisie texte ce qui me fait penser que c'est toi qui le reçoit dans un mail au même titre que le nom et l'adresse mail WEEMAIL...


Posté par: Hobby001
Posté le: 26 Mar 2020 à 19:14
Si on coche Envoyer un accusé de réception: Oui

La page suivante de configuration d'envoi par e-mail demande les paramètres suivants:

Sujet, Message et Élément contenant l'adresse e-mail du visiteur

Il n'y a qu'à fournir l'info


-------------
Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.



Imprimer la Page | Close Window

Forum Software by Web Wiz Forums® version 10.18 - http://www.webwizforums.com
Copyright ©2001-2014 Web Wiz Ltd. - http://www.webwiz.co.uk