Imprimer la Page | Close Window

IziHost - changement de la version PHP

Imprimé depuis: openElement Website
Categorie:

openElement


Nom du Forum: Discussion générale openElement
Description du Forum: Discussion générale sur le logiciel
URL: http://forum.openelement.com/en/forum_posts.asp?TID=23118
Date: Aug 24 2019 à 12:04am
Version logiciel: Web Wiz Forums 10.18 - http://www.webwizforums.com


Sujet: IziHost - changement de la version PHP
Posté par: Dmit OE
Sujet: IziHost - changement de la version PHP
Posté le: Dec 01 2017 à 3:07pm
Bonjour,

Pour ceux qui sont hébergés chez IziHost (ancien hébergement-partenaire OE qui ne l'est plus depuis quelques années): la version PHP est changée de 5.3 vers 7 car 5.3 est largement obsolète (je ne pense pas que vous trouverez encore un hébergement avec, elle n'est plus soutenu par l’équipe PHP).

Cela peut éventuellement causer des erreurs sur vos sites OE, si vous n'avez par mis a jour OE depuis longtemps. Si cela arrive: la dernière version OE est parfaitement compatible avec PHP7, donc:

- Installez la dernière version OE (cochez l'option "Conserver les anciennes versions" pendant l'install pour pouvoir revenir en cas de soucis); 

- Chargez votre projet, attendez la conversion

- Utilisez Projet->Export dans dossier pour minimiser des soucis de mise en ligne

- Soit mettez vous-même le résultat de l'Export via FileZilla, soit Projet->Publier pour laisser OE le faire mais surtout en mode Complète (et non Différentielle).

Cordialement
L’équipe OE



Réponses:
Posté par: brolysan
Posté le: Dec 01 2017 à 3:25pm
Bonne initiative que de l'annoncer, même si cela n'a plus rien à voir avec OE. Clap

-------------
https://sensode.com" rel="nofollow - sensode
http://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Ma biographie


Posté par: araignee
Posté le: Oct 17 2018 à 4:52pm
Merci pour cette info, je voulais une solution pour mes sites et ne savais pas si OE était compatible. Vous me rassurez. Je vais réviser mes sites suite à une bonne mise à jour.

-------------
Créations Araignée


Posté par: Titidutai
Posté le: Dec 20 2018 à 12:06pm
Bonjour,

Je viens de recevoir le message suivant de 1and1:

"À partir de décembre 2018, votre version 7.0 de PHP est dépassée si bien que vous ne bénéficiez plus de mises à jour de sécurité gratuites pour cette version."

J'ai actuellement la version PHP 7.0.32 avec OE 1.57 R9

Comment faire la mise à jour pour mettre la version 7.1 ou 7.2 demandée ?

Merci


-------------
parigne-cheval-aventures.com


Posté par: brolysan
Posté le: Dec 20 2018 à 12:10pm
Bonjour,

J'ai "discuté" avec eux ce matin, et aucune informations de ce côté. Même la version très ancienne de 5.5 est encore supportée. Plutôt un phising votre mail non?

-------------
https://sensode.com" rel="nofollow - sensode
http://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Ma biographie


Posté par: Titidutai
Posté le: Dec 20 2018 à 6:05pm
Bonsoir,

Je suis allé voir sur mon compte et j'ai la même chose, il est inscrit que le support de la communauté PHP est valable jusqu'en décembre 2018 pour le PHP 7.0
1and1 propose d'assurer le support de cette version contre rémunération supplémentaire ou nous invite à changer la version d'où ma question.

J'ai changé la version sur 1and1 (PHP 7.2) tout semble fonctionner. En testant les paramètres sur OE j'ai la version PHP 7.2.13.
Je l'ai modifié manuellement dans l'onglet "Avancées", est-ce indispensable ?

Merci


-------------
parigne-cheval-aventures.com


Posté par: JCD59
Posté le: Apr 19 2019 à 11:13am
Bonjour,
Je viens d'installer la dernière version d'openelement.
Mon Antivirus m'alerte sur une vulnérabilité qui concerne justement le programme PHP situe dans :

"C:\Program Files (x86)\openElement\openElement 1.57 R9\Lib\php\php.exe"

Comme informations j'ai ceci

Citer

Description

An infinite loop vulnerability was found in PHP, possibly 5.x before 5.6.28 and 7.x before 7.0.13. By exploiting this vulnerability malicious users can cause a denial of service. This vulnerability can be exploited remotely via a specially designed object in serialized data.


Technical details

Vulnerability was found in Zend/zend_exceptions.c.

Vulnerability is related to CVE-2015-8876.

Affected products

PHP 5.x before 5.6.28
PHP 7.x before 7.0.13

Solution

Update to the latest versions
http://php.net/downloads.php" rel="nofollow - Download PHP


On peut faire cette MAJ de PHP ?








Posté par: Hobby001
Posté le: Apr 19 2019 à 11:23am
En attendant que quelqu'un de plus qualifié que moi y réponde, ne le faites pas.

La version de php reçue avec openElement ne sert qu'en prévisualisation sur votre PC, personne d'autre n'y a accès.  

Votre hébergeur vous fournira une version plus robuste sur votre héergement.




-------------
Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose de gros. http://denislafrance.net" rel="nofollow - http://denislafrance.net


Posté par: JCD59
Posté le: Apr 20 2019 à 10:37am
OK
Merci


Posté par: Drsicol
Posté le: Apr 25 2019 à 4:54pm
Hey. Although not relevant anymore, thanks. It's nice that someone cares about others.



Imprimer la Page | Close Window

Forum Software by Web Wiz Forums® version 10.18 - http://www.webwizforums.com
Copyright ©2001-2014 Web Wiz Ltd. - http://www.webwiz.co.uk