Imprimer la Page | Close Window

Compteur de visites

Imprimé depuis: openElement Website
Categorie:

openElement


Nom du Forum: Discussion générale openElement
Description du Forum: Discussion générale sur le logiciel
URL: http://forum.openelement.com/en/forum_posts.asp?TID=22622
Date: Apr 20 2021 à 12:01pm
Version logiciel: Web Wiz Forums 10.18 - http://www.webwizforums.com


Sujet: Compteur de visites
Posté par: Zorglub
Sujet: Compteur de visites
Posté le: Mar 12 2017 à 1:09pm
Pour info, Suite au message suivant : "Call to undefined function json_decode() in <b>/mnt/113/sda/1/9/bazar.perso/WEFiles/Server/WECounter-v22.php</b> on line <b>141</b><br />" à l'ouverture de la page, j'ai supprimé le compteur de visite (J'ai essayé de le supprimer puis de le remettre sans succès).


-------------
YN



Réponses:
Posté par: brolysan
Posté le: Mar 12 2017 à 1:10pm
Bonjour
sans lien, point d'aide.
Et essayez de nous communiquer un peu plus d'informations aussi, quelle version d'OE, le type d'hébergement, etc.
Merci


-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: Dmit OE
Posté le: Mar 12 2017 à 2:10pm
Bonjour,

Le plus probablement vous avez une version PHP obsolete (4), il faut changer la version PHP sur votre hebergement, dans le panneau de controle (selon l'hebergement la procedure peut varier). PHP 4 est trop dangereuse et abandonnee depuis 10ans


Posté par: Zorglub
Posté le: Mar 13 2017 à 11:28am
Message posté par brolysan brolysan a écrit:

Bonjour
sans lien, point d'aide.
Et essayez de nous communiquer un peu plus d'informations aussi, quelle version d'OE, le type d'hébergement, etc.
Merci


-------------
YN


Posté par: Zorglub
Posté le: Mar 13 2017 à 12:47pm
Bonjour,
Je vous demande de bien vouloir m'excuser, néophyte sur ce forum, je pensais être  sous la rubrique version beta 1.57.R4. Il n'y avait pas d'erreur en version 1-56-R4 avant la mise à jour.
Ce compteur fonctionne en prévisualisation.

OE W7 64
Firefox 52.0 (32 bits)
hébergement chez free PHP 5.1.3RC4-dev

http://bazar.perso.free.fr/




-------------
YN


Posté par: Dmit OE
Posté le: Mar 13 2017 à 12:53pm
Version 1.56R4 supportait encore PHP4, mais pas PHP7 qui est de plus en plus utilisé. Il n'y avait pas de moyen humaine de faire compatible les deux, et je repete, PHP4 est completement obsolete et dangereuse.


Posté par: Dmit OE
Posté le: Mar 13 2017 à 12:56pm
Edit: d'accord, Free m'a encore eu. Ils utilisent PHP5, mais une tres ancienne version 5.1, qui est la derniere de ne pas encore avoir la fonction json_decode. Je ne savais pas que ca existe. 
Par contre ils ont quand meme ajoute une nouvelle version:
http://www.freenews.fr/freenews-edition-nationale-299/services-web-180/pages-perso-free-ajout-support-php-5-6" rel="nofollow - https://www.freenews.fr/freenews-edition-nationale-299/services-web-180/pages-perso-free-ajout-support-php-5-6


Posté par: Dmit OE
Posté le: Mar 13 2017 à 12:59pm
P.S. Leurs citation:
"puisque les versions de PHP proposées jusqu’à maintenant par Free étaient extrêmement datées (respectivement PHP 4.4.3 et 5.1.3)."


Posté par: Dmit OE
Posté le: Mar 13 2017 à 5:23pm
J'ai ajoute la correction pour la version officielle; pour vous, j'ai mis le code directement en ligne, mettez-le dans Projet->Htaccess->Ajouter->Script libre:

<IfDefine Free>
php56 1
</IfDefine>


Posté par: Zorglub
Posté le: Mar 17 2017 à 5:36pm
Merci beaucoup, j'ai fait la correction.
Cela fonctionne Wink

-------------
YN



Imprimer la Page | Close Window

Forum Software by Web Wiz Forums® version 10.18 - http://www.webwizforums.com
Copyright ©2001-2014 Web Wiz Ltd. - http://www.webwiz.co.uk