Imprimer la Page | Close Window

Mini tuto formulaire pour débutant

Imprimé depuis: Forum openElement
Categorie:

openElement


Nom du Forum: Tutoriaux utilisateurs
Description du Forum: Ecrivez ou consultez des tutoriaux OpenElement
Pas de questions dans cette rubrique merci.
URL: http://forum.openelement.com/fr/forum_posts.asp?TID=21085
Date: 31 Oct 2020 à 10:29
Version logiciel: Web Wiz Forums 10.18 - http://www.webwizforums.com


Sujet: Mini tuto formulaire pour débutant
Posté par: brolysan
Sujet: Mini tuto formulaire pour débutant
Posté le: 13 Juin 2015 à 14:02
Suite à http://forum.openelement.com/fr/forum_posts.asp?TID=21082&PID=132746&title=formulaire-de-contact#132746" rel="nofollow - une demande d'un des nouveau utilisateur , voilà un mini tuto pour mieux appréhender cette partie d'OE (OpenElement).
Crées ta page contact ou autre.
Place sur celle ci les éléments composants ton formulaire.
Pour chaque bloc où tu veux que tes visiteurs remplissent un champ (tel que nom, prénom, adresse, numéro de téléphone, etc), tu places sur ta page un champ de saisie de texte.



Une fois placé sur ta page, tu as donc un bloc avec 2 icônes en bas à gauche.
Le deuxième sert à lui spécifier les règles de validation que tu veux sur ce bloc là.


Cliques dessus.
La fenêtre des règles de validation s'ouvre.



Cliques sur Ajouter une règle et sélectionnes Prédéfinie



Tu te retrouves avec tout un choix d'options pour ce bloc. Généralement, pour tout ce qui est nom, adresse, etc, on choisis que Champ obligatoire. Double clic dessus pour l'ajouter à droite (règles ajoutées)


Tu peux ajouter autant de règles que tu veux (surtout pour les adresses mails par exemple)


Une fois la règle ajoutée (ou les règles selon ton bloc), cliques sur enregistrer.
Tu vas devoir maintenant indiquer le message d'erreur pour chaque règle que tu as choisi pour informer le visiteur en cas d'absence (pour des infos que tu juges obligatoire) ou d'erreur de sa part.

En l’occurrence, pour mon exemple, j'ai spécifié "Veuillez indiquer votre nom" :


Une fois les règles finies, si tu as spécifié des polices et/ou taille sur tes pages, fais de même pour ton bloc.

Menu du haut, onglet Zone de Style.




Cliques sur l'icône Cadre principal et sélectionnes ce que tu veux changer comme type dans le bloc



Une fois finie, va sur le menu de droite, onglet propriétés et changes le nom de ton bloc (tu verras pourquoi par la suite).



Pour ma part, je l'ai appelé bloc_nom pour l'exemple.

Si tu souhaites que tes visiteurs indiquent une adresse email et recevoir le formulaire avec comme expéditeur leur adresse email, il va falloir la aussi noter l'ID de l'élément. Cela servira dans la suite du tutoriel pour paramétrer le formulaire.

Dans mon exemple, j'ai renommé l'ID et lui ai donné le nom WEEMAIL



Pour le cas où tu veux que les visiteurs te laissent un message de plusieurs lignes, tu dois choisir un champ de saisie de texte multilignes.



Maintenant que tout tes blocs sont posés et que tu leurs as donné un nom, passons à la phase du bouton d'envoi du formulaire. Glisses le sur la page.



Tu peux le laisser comme tel, ou bien choisir un modèle déjà prêt existant. Pour cela, menu de droite, puis Styles, et onglet Modèles de Styles.


Pour changer le texte contenu dans le bouton de formulaire, tout menu de droite, onglet Propriétés, puis Edition et section Texte.



Penses là aussi à changer le nom du bouton de formulaire par exemple, bouton_formulaire.



Une fois mon modèle choisi et mon texte changé, voila ce que cela donne.




Autre possibilité :
Vous pouvez mettre un bloc de texte simple, mettre les formes et texte que vous voulez.
Du moment que vous indiquez la aussi un nom à l'élément.





Passons à la phase paramétrage maintenant de ton formulaire.

Déposes l'élément Envoi par e-mail sur ta page.



Une fenêtre s'ouvre normalement. Il va te falloir la renseigner.
Pour commencer, renseignes tous les champs que tu vois.


Rien de bien compliqué. Pour mon exemple, bien entendu, j'ai spécifié mon adresse, pensez à mettre la votre...Embarrassed
Le paramétrage par défaut d'OE (pour éviter le spam) est de spécifier un email d'expéditeur fixe (au lieu de celui du visiteur) ou bien de mettre l'ID de l'élément que renseigne vos visiteurs, pour ainsi récupérer l'email. A toi de voir si tu le souhaites de changer ou non.
Par expérience, mettez l'ID.

Une fois renseignée, tu cliques sur suivant. Tu vas aller sur la partie des messages de résultat de l'envoi email. Tu vas choisir (ou non) les messages de réussite ou d'erreur pour l'utilisateur.



Une fois changé (ou non), cliques sur suivant.


Nous voilà arrivé sur la partie crucial du paramétrage.
Si tu as bien renommé tes blocs comme je te l'ai indiqué, tu devrais comprendre sans problème.


Avec les flèches au centre, passes les éléments que tu souhaites recevoir par le biais du formulaire sur la fenêtre de droite.
En bas, sur la partie Bouton d'envoi, cherches ton élément Bouton de formulaire que tu as renommé. Le mien est BT ENVOYER.


Ensuite, cliques sur suivant.


Nous voilà sur la partie intitulé des champs dans l'email.

Mets le texte que tu veux voir apparaître dans le mail du formulaire.
Pour ma part, je spécifie toujours à quoi correspondant l'élément avec ensuite deux points (:)



Une fois renseigné, cliques sur suivant.


Cliques sur Terminer.

Tout est prêt, tu n'as plus qu'à mettre en ligne et à tester.



-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie



Réponses:
Posté par: Dmit OE
Posté le: 13 Juin 2015 à 14:26
Thumbs Up


Posté par: Bridet
Posté le: 26 Juin 2015 à 11:58
Alors, je l'avoue, je n'avais encore qu'adapté des formulaires.
Me trompé-je ou le nom d'un champ simple ou multilignes n'apparaît pas visuellement "automatiquement" et il faut bel et bien rajouter une ligne de texte?


Posté par: Hobby001
Posté le: 26 Juin 2015 à 12:25
Message posté par Bridet Bridet a écrit:

Alors, je l'avoue, je n'avais encore qu'adapté des formulaires.
Me trompé-je ou le nom d'un champ simple ou multilignes n'apparaît pas visuellement "automatiquement" et il faut bel et bien rajouter une ligne de texte?
 
C'est bien le cas (ou peut-être est-ce du à mon ignorance), il faut ajouter du texte pour indiquer le contenu désiré dans la case.  J'ai aussi changé la couleur du fond des champs que j'ai choisi de rendre obligatoires pour clarifier la situation.
 
Je n'ai pas trouvé de façon aisée de changer la disposition des éléments visibles du Captcha.
 
De plus j'ai éprouvé quelques difficultés avec le code proposé par OE pour un bouton "Effacer les cases" 
 
$(':input').clearFields();
 
 DMIT a fourni celui-ci à la place:
var t=$(\':input\').clearFields();
J'ai pu mettre deux formulaires différents sur une même page avec succes.
Chaque formulaire contient son propre envoi par email et son propre bouton pour effacer les cases. 
 
L'envoi par courriel fonctionne bien puisque nous sélectionnons les champs à envoyer
 
Le code cité plus haut pour vider les cases fait en sorte que le contenu des deux formulaires soit effacé quel que soit le bouton "Effacer" sélectionné.
 


-------------
https://www.denislafrance.net" rel="nofollow - Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.


Posté par: Bridet
Posté le: 26 Juin 2015 à 12:50
C'est bizarre car dans WIKI (on parle de boîte de saisie de texte) et sur mon ancien site, il semble que le nom du champ et la possibilité de mettre une image est automatique, y aurait-il un recul dans les options?


Posté par: brolysan
Posté le: 26 Juin 2015 à 14:47
les options ont changées au fil des mises à jour, le wiki n'est plus à jour.
On bosse dessus...Big smile


Posté par: Bridet
Posté le: 26 Juin 2015 à 18:08
Oui, il semble bien, donc confirme-moi, le Nom du champ (même si bien renseigné dans propriétés) n'apparaît plus automatiquement et il faut bel et bien insérer un texte simple ligne?
(J'ai essayé le copier/coller de mon ancien site (sous OE), ça ne marche pas.)


Posté par: Maurice306
Posté le: 26 Juin 2015 à 18:34
Message posté par Bridet Bridet a écrit:

Alors, je l'avoue, je n'avais encore qu'adapté des formulaires.
Me trompé-je ou le nom d'un champ simple ou multilignes n'apparaît pas visuellement "automatiquement" et il faut bel et bien rajouter une ligne de texte?
 
Message posté par Hobby001 Hobby001 a écrit:

C'est bien le cas (ou peut-être est-ce du à mon ignorance), il faut ajouter du texte pour indiquer le contenu désiré dans la case.  J'ai aussi changé la couleur du fond des champs que j'ai choisi de rendre obligatoires pour clarifier la situation.
 

Bonjour à tous,

La première partie vient de Microvinc, la seconde de Hobby001.

J'ai tout appliqué et c'est au poil, le texte dans l'élément s’efface automatiquement lorsque le visiteur veut y mettre ses propres données.

Effacer le Texte valeur de saisie dans un champ de formulaire

  

Pour chaque élément-champ en question (simple ligne ou multiligne), mettez dans la Propriété Classe Perso le class default-text.

Ajoutez un Bloc de Code Source type Javascript position Header avec le code:


$(function(){
    $('.default-text :input').focus(function(){ // quand on selectionne et commence a modifier le champ
        if (!$(this).data('defaultText'))
            $(this).data('defaultText', $(this).val());
        var defaultText = $(this).data('defaultText'); // texte de depart
        if ($(this).val() === defaultText)
            $(this).val(''); // enlever le texte si = texte par defaut
    });
    $('.default-text :input').blur(function(){ // quand on quitte le champ
        var defaultText = $(this).data('defaultText'); // texte de depart
        if (defaultText && !$(this).val())
            $(this).val(defaultText); // si le champ est vide, remettre texte par defaut
       
    });
});

Pour que le formulaire ne puisse pas être envoyé depuis le site sans les données que vous souhaitez faire paraître (nom, prénom etc...) vous devez procéder de la manière suivante :

Quand vous sélectionnez un champ, trois petits boutons apparaissent.(Si le formulaire est dans un panneau d'élément en mode relative il y a trois boutons s'il est en mode absolute, il n'y a que deux boutons)

http://www.hostingpics.net" rel="nofollow">

http://www.hostingpics.net" rel="nofollow">

Celui du milieu donne accès à des règles de validation.

- 1) Ajoutez la règle prédéfinie : Champ obligatoire avec vos textes

- 2) Ajoutez une règle de validation personnalisée avec dans expression régulière la formule   ^((?!blabla).)*$  

- 3) Remplacez blabla par le texte pour le champ.

(Le texte par défaut de la règle obligatoire devrait être remplacé ou modifié s'il était différent de celui de la règle personnalisée) (Soyez logique mettez les mêmes textes que dans la règle prédéfinie).




-------------
La vie est belle !!!....., elle est comme chacun se la fait. Ne soyez pas pressé, partez plus tôt, car il n'y a pas de personnes pressée elles ne sont qu'en retard !!!


Posté par: Maurice306
Posté le: 26 Juin 2015 à 18:52
Pour compléter dans l’esprit de Brolysan une petite image 

http://www.hostingpics.net" rel="nofollow">


-------------
La vie est belle !!!....., elle est comme chacun se la fait. Ne soyez pas pressé, partez plus tôt, car il n'y a pas de personnes pressée elles ne sont qu'en retard !!!


Posté par: Maurice306
Posté le: 26 Juin 2015 à 18:56
Message posté par Bridet Bridet a écrit:

Oui, il semble bien, donc confirme-moi, le Nom du champ (même si bien renseigné dans propriétés) n'apparaît plus automatiquement et il faut bel et bien insérer un texte simple ligne?
(J'ai essayé le copier/coller de mon ancien site (sous OE), ça ne marche pas.)

Si SI, en renseignant le le champ de texte par ce que le visiteur doit y apposer se voit bien et s'efface automatiquement avec le code ci-dessus Beer


-------------
La vie est belle !!!....., elle est comme chacun se la fait. Ne soyez pas pressé, partez plus tôt, car il n'y a pas de personnes pressée elles ne sont qu'en retard !!!


Posté par: Bridet
Posté le: 26 Juin 2015 à 19:00
Merci Maurice, mais je crois qu'on n'est pas sur la même longueur d'onde (je suis diplomate ce soir).
In illo tempore (jadis) il semble que quand on introduisait un champ de saisie de texte formulaire, son nom était automatiquement visible même qu'on pouvait mettre une jolie image à la place (plus une au survol).
Cela ne semble plus être le cas (je suis déçue ce soir).
Je suis en train d'essayer une entourloupe en copiant la page contact de mon ancien site (6 items) d'arbre en arbre (je suis bucolique ce soir).
Et donc un petit copier/coller des champs semble fonctionner au sein (rhâââ, je suis sexe ce soir) du projet.
Dommage que ces fonctionnalités aient disparu, serait-il possible de les réintroduire (je suis vraiment relax ce soir)?






Posté par: brolysan
Posté le: 26 Juin 2015 à 19:11
Je modiferai le tuto tout à l"heure.
Pour Bridet, non, certaines choses ont disparu, obsolètes hélas...Big smile


Posté par: Maurice306
Posté le: 26 Juin 2015 à 19:14
HO ! excuse Bridet, effectivement j'étais parti dans mon délire. Embarrassed

-------------
La vie est belle !!!....., elle est comme chacun se la fait. Ne soyez pas pressé, partez plus tôt, car il n'y a pas de personnes pressée elles ne sont qu'en retard !!!


Posté par: Maurice306
Posté le: 26 Juin 2015 à 19:51
Message posté par Bridet Bridet a écrit:

Merci Maurice, mais je crois qu'on n'est pas sur la même longueur d'onde (je suis diplomate ce soir).
In illo tempore (jadis) il semble que quand on introduisait un champ de saisie de texte formulaire, son nom était automatiquement visible même qu'on pouvait mettre une jolie image à la place (plus une au survol).
Cela ne semble plus être le cas (je suis déçue ce soir).


Bon Bridet, je reviens vers toi pour que tu puisse dormir en paix ce soir.

Si tu veux positionner une image dans ton champ de texte, tu le sélectionne, tu vas sur la partie haute gauche dans "Cadre principal" tu sélectionne "Champ de saisie de texte" et dans Style à droite "Arrière plan" tu choisi l'image que tu veux lui affecter. Tu fais pareil pour une couleur.

http://www.hostingpics.net" rel="nofollow">

http://www.hostingpics.net" rel="nofollow">


-------------
La vie est belle !!!....., elle est comme chacun se la fait. Ne soyez pas pressé, partez plus tôt, car il n'y a pas de personnes pressée elles ne sont qu'en retard !!!


Posté par: Bridet
Posté le: 27 Juin 2015 à 09:14
Merci Maurice, mais je ne voulais pas mettre d'image (c'était un exemple des anciennes possibilités) et encore moins dans le corps de texte.
Je voulais m'assurer qu'il n'était plus possible d'avoir  le titre de la zone appelé nom du champ à remplir automatiquement à gauche de la zone de saisie sans qu'on doive rajouter un champ texte normal http://wiki.openelement.com/fr/index.php?title=Bo%C3%AEte_de_saisie_de_texte

C'est dommage car c'était très responsive comme système vu que le champ se met automatiquement sous le titre si on réduit la fenêtre.



Posté par: Dmit OE
Posté le: 27 Juin 2015 à 13:02
Bonjour,

Vous pouvez mettre un Panneau d'elements, en mode "relative", mettre son Largeur max a quelque chose puis Largeur en % pour qu'il commence a se reduire si la fenetre est trop petite; puis mettez a l'interieur le champ et le "label" (element(s) texte etc.)

Cordialement
D


Posté par: Bridet
Posté le: 27 Juin 2015 à 13:06
Oui, Dmit, mais avoue qu'avant tout ça était plus rapide à insérer et régler, je ne comprends pas très bien pourquoi on a supprimé cette facilité qui fonctionne d'ailleurs toujours si on la copie d'un "vieux" site.


Posté par: dubois
Posté le: 04 Août 2015 à 18:53
bonjour et merci pour ce tuto afin de créer un formulaire.

Moi mon problème ce n'est pas celui de vouloir créer un formulaire c'est juste de changer la couleur 
de fond du formulaire ( gris ) et la couleur de fond des zones de saisies.

J'ai pris le modèle "responsive" ( le seul pour le moment du reste ) pour créer mon site.

Où alors faut-il pour résoudre mon problème que je détruise l'existant et me raccrocher au tuto ? 

Merci !


Posté par: Bridet
Posté le: 05 Août 2015 à 08:56
C'est la couleur du champ de saisie de texte que tu dois modifier (zone de style >couleur)


Posté par: dubois
Posté le: 05 Août 2015 à 10:50
OK Bridet, j'ai fait ce que tu m'as dit et ça marche !

encore merci 


Posté par: Frorgaba
Posté le: 17 Dec 2015 à 21:50
bonsoir,

j'ai bien suivi le tuto mais hélas, bine que le message "le lmessage a été envoyé" apparaisse après avoir cliqué sur le bouton d'envoi, je ne reçois pas de message à l'adresse mail indiquée. J'ai essayé avec plusieurs adresses différentes (eh oui j'en ai plusieurs) et aucun message n'est arrivé. Celà viendrait il de l'hébergeur?


Posté par: Hobby001
Posté le: 17 Dec 2015 à 22:12
Quel est l'hébergeur? et fournissez un lien sur votre page.

-------------
https://www.denislafrance.net" rel="nofollow - Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.


Posté par: Frorgaba
Posté le: 17 Dec 2015 à 23:14
le fourniseur est
hebergratuit.net

pepy-bricole.hebergratuit.net


Posté par: Hobby001
Posté le: 17 Dec 2015 à 23:46
Il y a effectivement des hébergeurs gratuits pour lesquels ça ne fonctionne pas. 

Nous verrons à partir de là ce que les pros en diront.  

Il faut aussi vérifier avec l'hébergeur pour connaître la version de php qu'ils offrent.






-------------
https://www.denislafrance.net" rel="nofollow - Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.


Posté par: Frorgaba
Posté le: 18 Dec 2015 à 10:59
j'ai effectivement teter avec un autre hébergeur (hostinger) et cela fonctionne sans soucis.
Merci encore pour vos informations.


Posté par: Larsene
Posté le: 18 Dec 2015 à 11:07
99,9% des hébergeurs gratuits sont moisis. Préférez un vrai hébergement.

Il faut croire que nous ne le répèterons jamais assez !


-------------
http://goo.gl/KXxG5Y" rel="nofollow - Tutos | https://goo.gl/EtcEUi" rel="nofollow - Don | https://bit.ly/2YwprN3" rel="nofollow - Image Sublime


Posté par: brolysan
Posté le: 18 Dec 2015 à 11:15
en forme mon larsène !!!! Big smile

-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: Bridet
Posté le: 18 Dec 2015 à 11:53
Tétons, tétons!




Posté par: Hobby001
Posté le: 18 Dec 2015 à 11:58
Message posté par Frorgaba Frorgaba a écrit:

j'ai effectivement teter avec un autre hébergeur (hostinger) et cela fonctionne sans soucis.
Merci encore pour vos informations.

Message posté par Bridet Bridet a écrit:

Tétons, tétons!




Il n'y a que Bridet pour tout voir comme ça!


-------------
https://www.denislafrance.net" rel="nofollow - Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.


Posté par: Bridet
Posté le: 18 Dec 2015 à 12:01
Message posté par Hobby001 Hobby001 a écrit:

Message posté par Frorgaba Frorgaba a écrit:

j'ai effectivement teter avec un autre hébergeur (hostinger) et cela fonctionne sans soucis.
Merci encore pour vos informations.

Message posté par Bridet Bridet a écrit:

Tétons, tétons!




Il n'y a que Bridet pour tout voir comme ça!


Et je me retiens souvent! ;-)


Posté par: Serval62
Posté le: 11 Jan 2016 à 23:23
Bonjour à tous,
Je viens de regarder ce tuto qui me parait bien détaillé et compréhensible même pour une buse comme moi.
Cependant, je rencontre un problème qui n'est pas évoqué dans le tutoCry :
Je fais partie de l'organisation d'une course à pied où chaque membre du comité a son rôle à jouer (inscriptions, partenariats, logistique, internet, etc...) et dispose donc de sa propre adresse mail (ex: inscriptions@domaine.fr).
J'ai donc bien compris comment mettre en place les différents champs tels que nom, prénom, adresse mail. En revanche, j'aimerai insérer un menu déroulant de type "votre question concerne" avec les différents sujets dispo. Le but, c'est que le mail soit acheminé vers un destinataire différent en fonction du sujet de la question posée.
J'aimerai aussi imposer la saisie d'un capcha (si ce n'est pas trop demandéWink).
Est-ce qu'une âme charitable serait en mesure de compléter le tuto afin de l'adapter à mes besoins.
Merci d'avance

edit : pour info, le site est www.lacanadianrace.fr et il est hébergé chez OVH. Ceci-dit, ça ne fera pas avancer le schmilbrick puisque actuellement un clic sur "nous contacter" fait ouvrir un mail dans le logiciel de messagerie et ne dirige pas vers la page du formulaire de contact (solution provisoire durant laquelle je récupère tous les messages reçus que je dois redispatcher. C'est chiant mais ça a été rapide à mettre en place)


Posté par: MicroVinc
Posté le: 11 Jan 2016 à 23:36
Bonjour, sur cette page il y a peut être 2 exemples qui peut vous intéresser, voir script 1 et script 2...
Pour voir le script il faut cliquer sur l'oeil.

http://microvinc.fr/Zone_Essai_Script_OE.php" rel="nofollow - ICI

-------------
-Éléments pour OpenElement : https://goo.gl/Wq3Cpp" rel="nofollow - ICI
-Tutoriels pour OpenElement : https://goo.gl/NdpS1i" rel="nofollow - ICI


La Bretagne, un État dans l'État


Posté par: Serval62
Posté le: 12 Jan 2016 à 23:32
Merci, je teste l'exemple 1 ASAP. Par contre, le top aurait été de n'avoir qu'un seul bouton d'envoi avec destinataire sélectionné en fonction du menu déroulant. Sur l'exemple 1, un bouton différent apparait pour chaque destinataire.


Posté par: MicroVinc
Posté le: 12 Jan 2016 à 23:43
Ils sont juste séparé pour mettre en évidant l'exemple...
Pour votre cas il faut les mettre les un sur les autres...

-------------
-Éléments pour OpenElement : https://goo.gl/Wq3Cpp" rel="nofollow - ICI
-Tutoriels pour OpenElement : https://goo.gl/NdpS1i" rel="nofollow - ICI


La Bretagne, un État dans l'État


Posté par: brolysan
Posté le: 13 Jan 2016 à 09:08
Message posté par MicroVinc MicroVinc a écrit:

Bonjour, sur cette page il y a peut être 2 exemples qui peut vous intéresser, voir script 1 et script 2...
Pour voir le script il faut cliquer sur l'oeil.

http://microvinc.fr/Zone_Essai_Script_OE.php" rel="nofollow - ICI

sympa tes scripts MicroVinc Clap


-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: Serval62
Posté le: 13 Jan 2016 à 13:54
Message posté par MicroVinc MicroVinc a écrit:

Ils sont juste séparé pour mettre en évidant l'exemple...
Pour votre cas il faut les mettre les un sur les autres...

Ben oui, c'est pourtant tellement évident. Parfois je me demande pourquoi je cherche toujours les complications Confused


Posté par: kllarinette
Posté le: 03 Feb 2016 à 16:29
Salut,
j'ai le même problème, mais ça marchait bien jusqu'à aujourd'hui ....
A la validation du formulaire il y a bien le message "bien envoyé", mais le mail ne me parvient pas. J'ai essayé avec une autre adresse mail, pareil. Par contre, j'ai demandé un accusé de réception, et lui, arrive correctement. Je suis passé aujourd'hui à la version 1.53R2, y aurait-il un rapport avec le problème ?
A vous lire.


Posté par: brolysan
Posté le: 03 Feb 2016 à 16:32
Message posté par kllarinette kllarinette a écrit:

Salut,
j'ai le même problème, mais ça marchait bien jusqu'à aujourd'hui ....
A la validation du formulaire il y a bien le message "bien envoyé", mais le mail ne me parvient pas. J'ai essayé avec une autre adresse mail, pareil. Par contre, j'ai demandé un accusé de réception, et lui, arrive correctement. Je suis passé aujourd'hui à la version 1.53R2, y aurait-il un rapport avec le problème ?
A vous lire.

je viens de tester, sur 5 projets sous la dernière béta, aucun problème, les mails arrivent bien.
regardez du côté de vos spams.
Au besoin, mettez l'ID de l'élément ou vos visiteurs doivent mettre leur adresse mail, pour contrôler.


-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: Hobby001
Posté le: 03 Feb 2016 à 16:38
Aucun souci de ce côté moi non plus

-------------
https://www.denislafrance.net" rel="nofollow - Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose
de gros.


Posté par: kllarinette
Posté le: 03 Feb 2016 à 17:40
Merci pour vos réponses. En fait c'est mon FAI (Free) qui bloque. (trop d'erreurs depuis mon IP) j'ai pas tout compris, mais je cherche...


Posté par: brolysan
Posté le: 03 Feb 2016 à 17:55
Message posté par kllarinette kllarinette a écrit:

Merci pour vos réponses. En fait c'est mon FAI (Free) qui bloque. (trop d'erreurs depuis mon IP) j'ai pas tout compris, mais je cherche...
un reboot de ta freebox devrait peut être résoudre tes soucis.


-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: patricia
Posté le: 04 Feb 2016 à 14:59
Bonjour à tous,
Je ne suis pas sure de poster au bon endroit car j'utilise le modèle responsive center01 mais mon souci concerne le formulaire de contact. J'ai utilisé ce tuto pour l'envoi par emails et la redirection du formulaire.
Version OE 1.53 R2  - Hébergeur Godaddy.
Lorsque je teste le formulaire d'envoi d'email j'ai un message me disant que l'email a bien été envoyé mais je ne reçois rien (rien dans les spams non plus).
L'adresse du site est:
http://www.dominica-caraibe.com/test" rel="nofollow - http://www.dominica-caraibe.com/test
Il s'agit d'un site d'apprentissage qui n'est pas destiné à être en ligne.
D'avance pour pour votre aide.
Cordialement,
Patricia


-------------
"Si tout ceux qui croient avoir raison n'avaient pas tort, la vérité ne serait pas loin" Pierre DAC


Posté par: brolysan
Posté le: 04 Feb 2016 à 15:22
Message posté par patricia patricia a écrit:

Bonjour à tous,
Je ne suis pas sure de poster au bon endroit car j'utilise le modèle responsive center01 mais mon souci concerne le formulaire de contact. J'ai utilisé ce tuto pour l'envoi par emails et la redirection du formulaire.
Version OE 1.53 R2  - Hébergeur Godaddy.
Lorsque je teste le formulaire d'envoi d'email j'ai un message me disant que l'email a bien été envoyé mais je ne reçois rien (rien dans les spams non plus).
L'adresse du site est:
http://www.dominica-caraibe.com/test" rel="nofollow - http://www.dominica-caraibe.com/test
Il s'agit d'un site d'apprentissage qui n'est pas destiné à être en ligne.
D'avance pour pour votre aide.
Cordialement,
Patricia

dans la configuration du mail, as tu bien spécifier l'ID de l'élément où les visiteurs doivent renseigner leur mail?


-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: patricia
Posté le: 04 Feb 2016 à 15:39
oui je l'ai fait. Je vais recommencer la procédure pour être sure de n'avoir rien oublié et je reviens vers toi. Merci.

-------------
"Si tout ceux qui croient avoir raison n'avaient pas tort, la vérité ne serait pas loin" Pierre DAC


Posté par: patricia
Posté le: 04 Feb 2016 à 16:30
J'ai tout recommencé et je ne pense pas avoir oublié quelque chose.
J'ai bien "votre message a bien été envoyé".
Sur la première fenêtre qui s'ouvre "configuration de l'envoi d'un formulaire vers une page externe": Je dois mettre l'adresse du site dans URL de destination mais ensuite je n'ai rien à modifier ?
Methode : Post
Cible : la même fenêtre
encryptage :text/plain
Bouton d'envoi: button
Bouton annulation : non
J'ai refais plusieurs tentatives sans succès Je ne reçois rien.
Peux-tu essayer de m'envoyer un email ?
Merci!


-------------
"Si tout ceux qui croient avoir raison n'avaient pas tort, la vérité ne serait pas loin" Pierre DAC


Posté par: brolysan
Posté le: 04 Feb 2016 à 17:44
Y a un bug lors de la saisie du formulaire, ca me m'indique rien du tout. A mon humble avis, tu as du "déteriorer" le template d'origine. Peux tu m'envoyer ton projet via wetransfert?

-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: patricia
Posté le: 04 Feb 2016 à 17:48
oups... je t'envoie ça.
Merci


-------------
"Si tout ceux qui croient avoir raison n'avaient pas tort, la vérité ne serait pas loin" Pierre DAC


Posté par: patricia
Posté le: 04 Feb 2016 à 18:03
Je viens de t'envoyer le lien en MP.
Merci!


-------------
"Si tout ceux qui croient avoir raison n'avaient pas tort, la vérité ne serait pas loin" Pierre DAC


Posté par: brolysan
Posté le: 04 Feb 2016 à 18:22
Message posté par patricia patricia a écrit:

Je viens de t'envoyer le lien en MP.
Merci!

en cours...et effectivement, des bourdes un peu partout dans la configuration du formulaire (y en a 3...)

edit : c'est bon, corrigé, voilà un http://bc-webdesign.fr/test/" rel="nofollow - lien de test pour contrôler .


-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: patricia
Posté le: 04 Feb 2016 à 18:42
Merci Brolysan  j'ai vu mes bourdes ... j'ai fait n'importe quoi ! Thumbs Down

-------------
"Si tout ceux qui croient avoir raison n'avaient pas tort, la vérité ne serait pas loin" Pierre DAC


Posté par: brolysan
Posté le: 06 Feb 2016 à 12:51
mise à jour du tuto sur la partie renseignement email de l'expéditeur. En ce moment,pas mal de blocage souvent lié au fait que l'on met deux fois la même adresse mail et donc se retrouve blacklisté tout seul.

-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: brolysan
Posté le: 16 Mar 2016 à 19:03
Tiens, petite demande de ma part...sur le formulaire Big smile si quelqu'un sait.
Sur un champ de saisie de texte,l est possible de choisir le texte dans celui ci (Valeur de saisie), de spécifier sa font et sa taille, même sa couleur. Ca tout le monde le sait.
Mais dans le cas où l'on souhaite une couleur différente lorsque les visiteurs cliquent dessus, y a une solution?

Je cherche là...


-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: Dmit OE
Posté le: 16 Mar 2016 à 23:32
Bloc de code CSS:

input:focus 
    color: blue !important;
}


Posté par: brolysan
Posté le: 17 Mar 2016 à 08:29
tiens, j'avais zappé cette fonction CSS...merci Maître Dmit...Thumbs Up

-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: brolysan
Posté le: 17 Mar 2016 à 13:01
Tiens Dmit, peux être que tu sais...mais dans le cas où je spécifie un accusé de réception, il arrive parfaitement, mais pourquoi le mail du destinataire est celui du visiteur et un mail spécifique?

-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: toitoit
Posté le: 17 Oct 2018 à 21:01
Bonjour Brosylan, super le tuto mais les images ne s'ouvrent pas. Donc je ne comprends pas tout ce que tu ecris en marge. Comment faire pour voir ces copies d'écrans.
Merci beaucoup

-------------
Tonio


Posté par: brolysan
Posté le: 18 Oct 2018 à 09:12
Message posté par toitoit toitoit a écrit:

Bonjour Brosylan, super le tuto mais les images ne s'ouvrent pas. Donc je ne comprends pas tout ce que tu ecris en marge. Comment faire pour voir ces copies d'écrans.
Merci beaucoup

il semble que le site hébergeant les images ait arrêté de fonctionner. Je vais voir pour les remettre.


-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie


Posté par: brolysan
Posté le: 19 Oct 2018 à 18:30
Mise à jour effectuée, les visuels ont été changés et hébergés ailleurs.
Bonne lecture Wink

-------------
https://sensode.com" rel="nofollow - Sensode
https://www.creads.fr/blog/graphiste-freelance2/parole-de-brolysan-45-ans-graphiste" rel="nofollow - Biographie



Imprimer la Page | Close Window

Forum Software by Web Wiz Forums® version 10.18 - http://www.webwizforums.com
Copyright ©2001-2014 Web Wiz Ltd. - http://www.webwiz.co.uk