Antivirus offre spéciale - jusqu'à 60 % de réduction avec openElement !
Accueil Forum Accueil Forum >

openElement

> Discussion générale openElement
  Nouveaux messages Nouveaux messages Fil RSS  - Album photos - nanoGALLERY
  FAQ FAQ  Rechercher dans le Forum   Inscription Inscription  Connexion Connexion

Album photos - nanoGALLERY

 Répondre Répondre
Auteur
Message
jjb1 allez vers le bas
Senior Member
Senior Member
Avatar

Depuis le: Feb 27 2013
Status: Inactif
Points: 391
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer jjb1 Citer  RépondreRéponse Lien Direct à ce Post Sujet: Album photos - nanoGALLERY
    Envoyé : Dec 01 2017 à 9:36pm

Bonjour à tous,

J'utilise NanoGallery pour mes albums photos, stockés chez FlickR, depuis que Google+ est devenu une usine à gaz (n'est pas Hobby001).

Jusqu'à ces derniers jours, tout fonctionnait bien, mais je constate aujourd'hui que mes vignettes n'apparaissent plus, alors que les images sont toujours accessibles (en cliquant sur une vignette grisée).

Voici un lien sur mon dernier album :

Mon Album

Savez-vous d’où peut provenir cette anomalie.

D'avance merci de votre aide.

Version OE :1 57R9
Haut de la page
Hobby001 allez vers le bas
Moderator Group
Moderator Group
Avatar
Modérateur

Depuis le: Feb 14 2015
Pays: Canada
Status: Inactif
Points: 3517
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer Hobby001 Citer  RépondreRéponse Lien Direct à ce Post Envoyé : Dec 02 2017 à 1:25am
Dites donc, ils ont l'air plutôt sérieux les chasseurs.  C'est peut-être pour ça que les photos ne s'affichent pas... Wink

Non franchement, je n'ai aucune idée de la raison de ce manque.  J'ai vérifié un autre site avec Google et ça roule toujours bien.  Disapprove



Quand on veut mettre quelque chose en ligne on se fait prendre par quelque chose de gros
Haut de la page
jjb1 allez vers le bas
Senior Member
Senior Member
Avatar

Depuis le: Feb 27 2013
Status: Inactif
Points: 391
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer jjb1 Citer  RépondreRéponse Lien Direct à ce Post Envoyé : Dec 02 2017 à 8:18am
Ces chasseurs là sont à l'écoute du président sur les consignes de chasse, ceci explique cela ; les retours de chasse sont beaucoup plus détendus !

Concernant nanoGallery2, j'ai vu qu'une version 2 du 30/11/2017 est apparue, mais je ne vois pas en quoi cela pourrait polluer les albums précédents.
Je vais tenter de me rapprocher de Christophe Bribois.
Version OE :1 57R9
Haut de la page
Dmit OE allez vers le bas
Admin Group
Admin Group
Avatar

Depuis le: May 31 2012
Status: Inactif
Points: 13671
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer Dmit OE Citer  RépondreRéponse Lien Direct à ce Post Envoyé : Dec 03 2017 à 12:53pm
Je ne peux pas dire ce que c'est passé, mais la balise-conteneur des images-miniatures n'a pas de hauteur (les balises interieures, notamment celle avec l'image, est en position absolute donc elle n'affecte pas la hauteur du conteneur). Pour essayer de corriger vite, ajoutez un Bloc de Code Source type CSS (ou utilisez un existant) avec le code:

.nGY2GThumbnailSub { height: 100%; }
Haut de la page
jjb1 allez vers le bas
Senior Member
Senior Member
Avatar

Depuis le: Feb 27 2013
Status: Inactif
Points: 391
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer jjb1 Citer  RépondreRéponse Lien Direct à ce Post Envoyé : Dec 03 2017 à 1:29pm
Bonjour Dmit,
Je viens de suivre votre conseil, et CA FONCTIONNE.
Merci mille fois, car j'étais dans une totale impasse.
Je ne m'explique pas la raison de cette modification subite qui plus est, touche tous mes albums logés chez FlickR.
J'ai vérifié les codes sur le site nanoGallery2, je n'ai rien vu d'anormal, et je n'ai pas d'écho au message que j'ai adressé à C. Bribois.
Ne me reste plus qu'à intervenir sur chacun de mes albums (je vais tenter avec un calque).
Merci encore, et bon dimanche.
Version OE :1 57R9
Haut de la page
jjb1 allez vers le bas
Senior Member
Senior Member
Avatar

Depuis le: Feb 27 2013
Status: Inactif
Points: 391
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer jjb1 Citer  RépondreRéponse Lien Direct à ce Post Envoyé : Dec 05 2017 à 6:56pm
Bonjour,
Voici la réponse que je reçois de Chris Bribois, suite à ma sollicitation :
Bonjour Jean-Jacques,
La version 2.0.0 est sortie le 30/11/2017, et comme votre page recherche la dernière version sur le CDN, votre site a ainsi été mis à jour automatiquement.
Pour info :
- pour une version particulière (exemple 1.5.0) : https://unpkg.com/nanogallery2@1.5.0/dist/jquery.nanogallery2.min.js

Je conseille la dernière syntaxe pour éviter les mises à jour automatiques.
Il doit y avoir une incompatibilité avec Open Element. Votre galerie fonctionne parfaitement sous codepen par exemple : https://codepen.io/Kris-B/pen/bYJgNO
Quelle solution de contournement vous a été fournie par OpenElement?
Merci,
Chris
PS: je préfère l'utilisation de Github, même en français, pour ce type de question : cela permet de partager avec d'autres personnes qui pourraient être confrontées au même problème.

Cette solution (version 1.5) résout bien le problème des vignettes, mais ne donne plus accès aux images.
Je vous cela transmet à titre d'information, car je conserve la solution de Dmit.
Version OE :1 57R9
Haut de la page
 Répondre Répondre
  Partagez ce sujet   

Aller au Forum Permissions du forum allez vers le bas

Forum Software by Web Wiz Forums® version 10.18
Copyright ©2001-2014 Web Wiz Ltd.

Cette page a été affichée en 0,046 secondes.
Réserver en ligne un taxi, vtc, navette