Antivirus offre spéciale - jusqu'à 60 % de réduction avec openElement !
Accueil Forum Accueil Forum >

openElement

> Élements complémentaires pour OE
  Nouveaux messages Nouveaux messages Fil RSS  - IziHost - changement de la version PHP
  FAQ FAQ  Rechercher dans le Forum   Inscription Inscription  Connexion Connexion

IziHost - changement de la version PHP

 Répondre Répondre
Auteur
Message
Dmit OE allez vers le bas
Admin Group
Admin Group
Avatar

Depuis le: 31 Mai 2012
Status: Inactif
Points: 14010
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer Dmit OE Citer  RépondreRéponse Lien Direct à ce Post Sujet: IziHost - changement de la version PHP
    Envoyé : 01 Dec 2017 à 16:07
Bonjour,

Pour ceux qui sont hébergés chez IziHost (ancien hébergement-partenaire OE qui ne l'est plus depuis quelques années): la version PHP est changée de 5.3 vers 7 car 5.3 est largement obsolète (je ne pense pas que vous trouverez encore un hébergement avec, elle n'est plus soutenu par l’équipe PHP).

Cela peut éventuellement causer des erreurs sur vos sites OE, si vous n'avez par mis a jour OE depuis longtemps. Si cela arrive: la dernière version OE est parfaitement compatible avec PHP7, donc:

- Installez la dernière version OE (cochez l'option "Conserver les anciennes versions" pendant l'install pour pouvoir revenir en cas de soucis); 

- Chargez votre projet, attendez la conversion

- Utilisez Projet->Export dans dossier pour minimiser des soucis de mise en ligne

- Soit mettez vous-même le résultat de l'Export via FileZilla, soit Projet->Publier pour laisser OE le faire mais surtout en mode Complète (et non Différentielle).

Cordialement
L’équipe OE
Haut de la page
brolysan allez vers le bas
Admin Group
Admin Group
Avatar

Depuis le: 14 Août 2009
Pays: France
Status: Inactif
Points: 9258
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer brolysan Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 01 Dec 2017 à 16:25
Bonne initiative que de l'annoncer, même si cela n'a plus rien à voir avec OE. Clap
Haut de la page
araignee allez vers le bas
Newbie
Newbie
Avatar

Depuis le: 12 Mai 2014
Pays: Canada
Status: Inactif
Points: 11
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer araignee Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 17 Oct 2018 à 17:52
Merci pour cette info, je voulais une solution pour mes sites et ne savais pas si OE était compatible. Vous me rassurez. Je vais réviser mes sites suite à une bonne mise à jour.

Edité par araignee - 17 Oct 2018 à 17:53
Créations Araignée
Haut de la page
Titidutai allez vers le bas
Groupie
Groupie
Avatar

Depuis le: 10 Mai 2016
Pays: France
Status: Inactif
Points: 61
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer Titidutai Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 20 Dec 2018 à 13:06
Bonjour,

Je viens de recevoir le message suivant de 1and1:

"À partir de décembre 2018, votre version 7.0 de PHP est dépassée si bien que vous ne bénéficiez plus de mises à jour de sécurité gratuites pour cette version."

J'ai actuellement la version PHP 7.0.32 avec OE 1.57 R9

Comment faire la mise à jour pour mettre la version 7.1 ou 7.2 demandée ?

Merci
parigne-cheval-aventures.com
Haut de la page
brolysan allez vers le bas
Admin Group
Admin Group
Avatar

Depuis le: 14 Août 2009
Pays: France
Status: Inactif
Points: 9258
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer brolysan Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 20 Dec 2018 à 13:10
Bonjour,

J'ai "discuté" avec eux ce matin, et aucune informations de ce côté. Même la version très ancienne de 5.5 est encore supportée. Plutôt un phising votre mail non?
Haut de la page
Titidutai allez vers le bas
Groupie
Groupie
Avatar

Depuis le: 10 Mai 2016
Pays: France
Status: Inactif
Points: 61
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer Titidutai Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 20 Dec 2018 à 19:05
Bonsoir,

Je suis allé voir sur mon compte et j'ai la même chose, il est inscrit que le support de la communauté PHP est valable jusqu'en décembre 2018 pour le PHP 7.0
1and1 propose d'assurer le support de cette version contre rémunération supplémentaire ou nous invite à changer la version d'où ma question.

J'ai changé la version sur 1and1 (PHP 7.2) tout semble fonctionner. En testant les paramètres sur OE j'ai la version PHP 7.2.13.
Je l'ai modifié manuellement dans l'onglet "Avancées", est-ce indispensable ?

Merci


Edité par Titidutai - 21 Dec 2018 à 08:38
parigne-cheval-aventures.com
Haut de la page
JCD59 allez vers le bas
Newbie
Newbie
Avatar

Depuis le: 18 Oct 2018
Pays: FRANCE
Status: Inactif
Points: 17
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer JCD59 Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 19 Avr 2019 à 12:13
Bonjour,
Je viens d'installer la dernière version d'openelement.
Mon Antivirus m'alerte sur une vulnérabilité qui concerne justement le programme PHP situe dans :

"C:\Program Files (x86)\openElement\openElement 1.57 R9\Lib\php\php.exe"

Comme informations j'ai ceci

Citer

Description

An infinite loop vulnerability was found in PHP, possibly 5.x before 5.6.28 and 7.x before 7.0.13. By exploiting this vulnerability malicious users can cause a denial of service. This vulnerability can be exploited remotely via a specially designed object in serialized data.


Technical details

Vulnerability was found in Zend/zend_exceptions.c.

Vulnerability is related to CVE-2015-8876.

Affected products

PHP 5.x before 5.6.28
PHP 7.x before 7.0.13

Solution

Update to the latest versions
Download PHP


On peut faire cette MAJ de PHP ?






Haut de la page
Hobby001 allez vers le bas
Admin Group
Admin Group
Avatar
Modérateur

Depuis le: 14 Feb 2015
Pays: Canada QC
Status: Inactif
Points: 4473
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer Hobby001 Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 19 Avr 2019 à 12:23
En attendant que quelqu'un de plus qualifié que moi y réponde, ne le faites pas.

La version de php reçue avec openElement ne sert qu'en prévisualisation sur votre PC, personne d'autre n'y a accès.  

Votre hébergeur vous fournira une version plus robuste sur votre héergement.


Quand on veut mettre quelque chose en ligne, on se fait prendre par quelque chose de gros.
Haut de la page
JCD59 allez vers le bas
Newbie
Newbie
Avatar

Depuis le: 18 Oct 2018
Pays: FRANCE
Status: Inactif
Points: 17
Options des messages Options des messages   Thanks (0) Thanks(0)   Citer JCD59 Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 20 Avr 2019 à 11:37
OK
Merci
Haut de la page
 Répondre Répondre
  Partagez ce sujet   

Aller au Forum Permissions du forum allez vers le bas

Forum Software by Web Wiz Forums® version 10.18
Copyright ©2001-2014 Web Wiz Ltd.

Cette page a été affichée en 0,027 secondes.
Acheter votre vélo en ligne